WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27815 closed defect (bug) (fixed)

PHP Warning during Background updates w/ Themes

Reported by: dd32 Owned by: dd32
Milestone: 3.9 Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

The following warning is triggered during background updates if there are any theme updates available and the site has multiple theme directories registered.

PHP Warning:  Illegal offset type in isset or empty in wp-includes/theme.php on line 614

This is caused by passing the update object to get_theme_root() instead of the theme slug, when there's only 1 theme directory registered (The default one) the function returns early and doesn't look at the theme slug provided, if there are multiple directories however, it treats the slug as a string and hits the above warning.

When the warning is hit, the default theme directory is returned, so all updates were still flowing despite the warning.

Change History (1)

#1 @dd32
7 years ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 28137:

Background Updates: Avoid a PHP warning during theme update checks when there are multiple theme directories registered. Fixes #27815

Note: See TracTickets for help on using tickets.