WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#27820 closed defect (bug) (invalid)

mediaelementplayer.min.css and wp-mediaelement.css loading twice in WordPress 3.9-RC2 on TinyMCE pages

Reported by: n7studios Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords:
Focuses: administration Cc:

Description

Using the latest WordPress (3.9-RC2), I have noticed that mediaelementplayer.min.css and wp-mediaelement.css are loading twice, once in WordPress, and once through TinyMCE - on any page that loads TinyMCE.

On an admin page that does not load TinyMCE, these files are not loaded at all (expected behaviour). I have attached a screenshot of Chrome's Network > Stylesheets tab which indicates the files being loaded more than once each.

Do these files need to be loaded twice (a total of four times across both files), or should they just be loaded once each?

This was discovered as we were investigating an issue in relation to the limits of CSS styles that can be loaded in IE6-9. More information on this issue in IE is available here: http://support.microsoft.com/kb/262161

Attachments (1)

mediaelement.png (232.5 KB) - added by n7studios 4 years ago.
Chrome Network > Stylesheets

Download all attachments as: .zip

Change History (2)

@n7studios
4 years ago

Chrome Network > Stylesheets

#1 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

That's correct. The reason therefore is, that TinyMCE uses an iframe for the content. In this iframe we have to load the files again. Same for dashicons.css btw.

For the record: Mediaelement,js is used for the mceViews (inside TinyMCE) and for the media uploader (outside TinyMCE).

Last edited 4 years ago by ocean90 (previous) (diff)
Note: See TracTickets for help on using tickets.