WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#27854 closed defect (bug) (invalid)

Updating the discussion settings does not work over ssl

Reported by: mossyoak Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.3
Component: Administration Keywords:
Focuses: Cc:

Description

I have noticed that when I force ssl in admin the settings for the discussion always redirects to a 404 instead of updating properly.
When deactivating ssl it works as normal.

Change History (5)

#1 @UmeshSingla
6 years ago

  • Keywords 2nd-opinion added

Couldn't replicate in 3.9 over ssl, works absolutely fine.

Need someone to check in 3.8.3 over https

#2 @mossyoak
6 years ago

I've tried this on a fresh install to check its not plugins or anything.
Tried installing a fresh test site in cpanel Softaculous (latest version of WordPress) using https protocol so the site is all ssl, and the discussion settings always re-direct to wp-admin/options.php which results in a 404.
This did not used to happen because I've not had this issue before now.

I also tried it on sites with no ssl and it worked fine as usual updating discussion settings with no problem.

Trying it on a site that was not installed with the https protocol but normal http protocol, only did not work when I set it to use ssl over admin in the wp-config file- otherwise works fine without ssl.
It's only the discussion settings that are not updating- everything else is working fine over ssl.

Thanks

#3 @mossyoak
6 years ago

I tried it again and it started working! I think I must have had something wrong with my ssl- recently had it renewed so perhaps it sorted my issue out.
Sorry about that- I guess it was a server issue.

#4 @UmeshSingla
6 years ago

  • Keywords 2nd-opinion removed
  • Resolution set to invalid
  • Status changed from new to closed

#5 @ocean90
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.