WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27861 closed defect (bug) (fixed)

TB_iframe is placed below the left menu in WordPress 3.9

Reported by: KalleL Owned by: nacin
Milestone: 3.9.1 Priority: normal
Severity: normal Version: 3.9
Component: General Keywords: has-patch commit fixed-major
Focuses: ui, administration Cc:

Description

TB_iframe is placed below the left menu in WordPress 3.9

Attachments (4)

3.8.3.jpg (179.6 KB) - added by KalleL 7 years ago.
3.9.jpg (199.6 KB) - added by KalleL 7 years ago.
plugin-update-details-modal-menu-z-index.png (70.2 KB) - added by celloexpressions 7 years ago.
Issue in core plugin update details modal.
27861.diff (897 bytes) - added by celloexpressions 7 years ago.
Remove version from thickbox styles.

Download all attachments as: .zip

Change History (13)

@KalleL
7 years ago

@KalleL
7 years ago

This ticket was mentioned in IRC in #wordpress-dev by [1]KaOs. View the logs.


7 years ago

@celloexpressions
7 years ago

Issue in core plugin update details modal.

#2 @celloexpressions
7 years ago

  • Focuses ui added
  • Keywords needs-patch added

Thanks for the report, KalleL!

I noticed this same issue with a core modal on one site, but had trouble replicating again. Then I ran into it on another site. The plugin details modal on the updates screen also exhibits the bug (it uses a thickbox).

Specifically, this is an issue when the sticky admin menu is active (menu height is smaller than window height), in that the menu displays above the overlay. It becomes more of an issue at smaller widths when the menu is on top of the modal window. The fix should be a matter of tweaking z-indexes of the modal and the overlay, probably to match those.

This is a 3.9 regression, so it should be considered for 3.9.1.

#3 @iseulde
7 years ago

  • Focuses administration added
  • Keywords reporter-feedback added

Thanks for the reports!
Could someone give me specific steps to reproduce this?
The z-index of the Thickbox modals is 100,050. That of the adminbar and sticky menu are 99,999 and 9,999 respectively.

#4 @celloexpressions
7 years ago

  • Keywords reporter-feedback removed

Looks like this is actually a caching issue. In 3.9 the version string for wp-includes/js/thickbox/thickbox.css is still 20131201, the same as 3.8.

The old file is loading the z-index of 510 instead of the newer value on some of my installs. Refreshing should fix the issue in most browsers, but we should probably bump the version string in the point release to break the browser caching without user intervention, just to be safe.

#5 @nacin
7 years ago

  • Milestone changed from Awaiting Review to 3.9.1

Let's remove the version string entirely so it uses the WP version as we have beyond forked it at this point.

@celloexpressions
7 years ago

Remove version from thickbox styles.

#6 @celloexpressions
7 years ago

  • Keywords has-patch added; needs-patch removed

#7 @nacin
7 years ago

In 28176:

Remove version string from Thickbox so it assumes the WP core version. Bust some caches.

props celloexpressions.
see #27861, for trunk.

#8 @nacin
7 years ago

  • Keywords commit fixed-major added

#9 @nacin
7 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 28228:

Rmove version string from Thickbox so it assumes the WP core version. Bust some caches.

Merges [28176] to the 3.9 branch.

props celloexpressions.
fixes #27861.

Note: See TracTickets for help on using tickets.