WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27875 closed defect (bug) (duplicate)

Annoying issue with linked image in the visual editor in some browsers

Reported by: adambaldwin99 Owned by:
Milestone: Priority: normal
Severity: major Version: 3.9
Component: Media Keywords:
Focuses: Cc:

Description

Why developing in Wordpress I prefer to use a lightweight browser as I tend to have loads of tabs open - as I use OSX I prefer to use browsers such as Roccat Browser or iCab:

https://www.macupdate.com/app/mac/37403/roccat-browser
https://www.macupdate.com/app/mac/5558/icab

Both of which are main steam alternative lightweight browsers for OSX, when I go to visual editor and click on a linked image I expect the edit and delete button to appear - however under these browsers it loads these buttons and then opens the link in the editor (or sometimes just opens the link in the editor without the buttons) making it impossible to use - I have discovered this issue on various other webkit browsers such as Sunrise, Sleipnir and Omniweb - which is annoying as Firefox and Chrome are resource hogs and makes my Mac hot when developing - and I hate Safari.

Here is a screenshot of it loading the URL in the editor in Wordpress 3.8
http://i.imgur.com/RWaFjg7.png

I thought that in 3.9 because you have changed the media functionality a lot that you may have fixed the bug, but unfortunately it's still occurring.

Change History (2)

#1 @adambaldwin99
7 years ago

  • Severity changed from normal to major

#2 @helen
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27874.

Note: See TracTickets for help on using tickets.