Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#27879 closed defect (bug) (fixed)

Can no longer drag images around in a table

Reported by: breadofthepresence's profile breadofthepresence Owned by:
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Since upgrading to 3.9, I can no longer drag an image from one table cell (<td>) to another in visual mode, which I was able to do before the upgrade.

I must say that sizing the images in visual mode is now much easier, but I have to go to text mode and move the images from cell to cell - which works - but is very tedious if I need to move the image several cells away, or maybe a few rows away from where it is.

Am I missing something, or is it no longer possible to drag the images around a table in visual mode?

Change History (9)

#1 @nacin
10 years ago

  • Milestone changed from Awaiting Review to 3.9.1

#2 @azaozz
10 years ago

  • Keywords reporter-feedback added

Cannot reproduce in Chrome, Firefox and IE. Dragging images without captions works as expected, including dragging between table cells and in/out of tables.

Images with captions are not draggable as when dragged, they will end up outside the caption elements and break the caption. This is the same behavior as in 3.8.

Last edited 10 years ago by azaozz (previous) (diff)

#3 @SergeyBiryukov
10 years ago

  • Component changed from General to Editor

#4 @UmeshSingla
10 years ago

With Caption the image can not be dragged at all in Firefox and Chrome, but without caption it works smoothly in both the browsers in WordPress 3.9

#5 @iseulde
10 years ago

  • Component changed from Editor to TinyMCE
  • Keywords reporter-feedback removed

I can reproduce this in Safari 7.0.2 and it worked pre-3.9.

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.


10 years ago

#7 @nacin
10 years ago

  • Milestone changed from 3.9.1 to 3.9.2

Specific to Safari, needs to be reported upstream (being done by azaozz)... Moving off 3.9.1.

#8 @spocke
10 years ago

Fixed this bug Safari seems to do something really special when you start dragging an unselected image and this messed up the "anti span" logic we have for drag/drop fixed here:
https://github.com/tinymce/tinymce/commit/7d9350c532bb90ba3681a3b7d6ff6a3b3ced3028

It also fixes the issue where custom table cell selection isn't properly ended on a drop event.

#9 @azaozz
10 years ago

  • Milestone changed from 3.9.2 to 4.0
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in TinyMCE 4.1.

Note: See TracTickets for help on using tickets.