WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 7 years ago

#2788 closed defect (bug) (fixed)

Strange behaviour when adding custom field to page

Reported by: halsnalle Owned by: pishmishy
Milestone: 2.5 Priority: normal
Severity: normal Version: 2.0.2
Component: Administration Keywords: page editing custom fields has-patch tested
Focuses: Cc:

Description

When adding a custom field to a Page, clicking "Add custom field" simply saves the page and loads the Write Post page. However, when I edit the saved page and add additional custom fields, clicking "Add custom field" works like "Save and continue editing, ie. I stay on the Edit Page page for the Page being edited.

Attachments (2)

2788.diff (2.5 KB) - added by davidhouse 9 years ago.
2788.2.diff (994 bytes) - added by pishmishy 7 years ago.
Corrects typo addemeta -> addmeta

Download all attachments as: .zip

Change History (11)

comment:1 @davidhouse9 years ago

"When adding a custom field to a Page, clicking "Add custom field" simply saves the page and loads the Write Post page." -- It redirects to the Write Page page for me, guess that was a typo.

Anyway, I think it should behave as a 'Save and continue editing' all the time.

comment:2 @davidhouse9 years ago

  • Owner changed from anonymous to davidhouse
  • Status changed from new to assigned

Almost done.

@davidhouse9 years ago

comment:3 @davidhouse9 years ago

  • Keywords bg|has-patch added

Try that patch.

comment:4 @Nazgul8 years ago

  • Keywords has-patch added; bg|has-patch removed
  • Milestone set to 2.3

comment:5 @westi7 years ago

  • Keywords needs-patch added; has-patch removed
  • Owner changed from davidhouse to westi
  • Status changed from assigned to new

I can confirm that this behaviour still exists.

The current patch is stale though -> has-patch=>needs-patch

comment:6 @foolswisdom7 years ago

  • Milestone changed from 2.3 to 2.4

comment:7 @pishmishy7 years ago

  • Owner changed from westi to pishmishy
  • Status changed from new to assigned

Problem still exists (sort of) in the new interface.
Adding a new custom field either with an existing page, or a page under creation, redirects me to the Write Page page. Should be changed to act as "Save and continue editting"

@pishmishy7 years ago

Corrects typo addemeta -> addmeta

comment:8 @pishmishy7 years ago

  • Keywords has-patch tested added; needs-patch removed

Problem in new interface is caused by a typo. Attached patch fixes it.

comment:9 @ryan7 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6816]) Fix add custom field redirects. Props pishmishy. fixes #2788

Note: See TracTickets for help on using tickets.