WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#27885 closed defect (bug) (worksforme)

Cannot edit existing Image CSS Class

Reported by: MarkRichardson Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

After updating to WP 3.9 I cannot edit the existing 'Image CSS Class' in the advanced section of the in-Page image editor. I can see the class is there via the 'Text' view but it does not show in Visual View's 'Image Details - Advanced'.

Change History (4)

#1 @helen
6 years ago

  • Keywords reporter-feedback added

We purposefully hide WP default classes from that particular image edit view because so many themes and the visual editor depend on them. They're there in the text view if you really need to tinker with them. Any custom classes should still appear, though - are those also a problem?

#2 @SergeyBiryukov
6 years ago

  • Component changed from General to Editor

#3 @nacin
6 years ago

It was also hidden because removing an existing CSS class also severs the link between the image and the attachment and can break the media manager and prevent the image from being edited again (this is specific to 3.9).

#4 @iseulde
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No feedback in 8 months and I can't reproduce. Please reopen with more information if this is still a problem.

Note: See TracTickets for help on using tickets.