WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#27892 closed defect (bug) (fixed)

Video playlist preview problems

Reported by: pavelevap Owned by: nacin
Milestone: 3.9.1 Priority: normal
Severity: normal Version: 3.9
Component: Media Keywords: has-patch commit fixed-major
Focuses: javascript Cc:

Description

I uploaded 2 testing videos (default from Windows Vista, format .wmv) and created video playlist.

First screenshot shows it in visual editor (second video title is hidden in black line).

Second screenshot is from frontend, big video icon does not look nice, I guess.

Attachments (5)

Video_playlist_editor.jpg (19.1 KB) - added by pavelevap 6 years ago.
Video_playlist_frontend.jpg (14.8 KB) - added by pavelevap 6 years ago.
Video_editor.jpg (9.2 KB) - added by pavelevap 6 years ago.
Video_frontend.jpg (22.0 KB) - added by pavelevap 6 years ago.
27892.diff (2.5 KB) - added by wonderboymusic 6 years ago.

Download all attachments as: .zip

Change History (22)

#1 @nacin
6 years ago

Browser? Which theme, does it have an editor stylesheet?

#2 @pavelevap
6 years ago

Chrome, Twenty Fourteen.

When I insert only one video (and not the whole playlist), it looks fine on frontend, but no preview in editor. Screenshots following...

#3 @wonderboymusic
6 years ago

  • Component changed from General to Media
  • Focuses javascript added
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.9.1

2 things are wrong:

  1. Playlists in the admin need to do the same native-compatibility tests that shortcodes do, otherwise Flash and Silverlight will bubble errors directly from the VM when loading videos like this
  1. Playlists need to never show the default icon for videos blown up, missed that one
Last edited 6 years ago by wonderboymusic (previous) (diff)

#4 @wonderboymusic
6 years ago

In 28158:

Don't set the poster image for videos in a playlist if the image is the video mime-type icon blown up.

See #27892.

#5 @pavelevap
6 years ago

Perfect, default icon is away. But when there is no "Featured image" set, only black color can be seen. I would expect automatic preview of first video file in playlist?

#6 @wonderboymusic
6 years ago

I am still working on it, taking it one step at a time

#7 @pavelevap
6 years ago

Sorry :-) I am playing with this feature for the first time and I am really impressed. There are some annoying problems with UX and localization problems, but great work as a whole!

@wonderboymusic
6 years ago

#8 @wonderboymusic
6 years ago

  • Keywords has-patch added; needs-patch removed

27892.diff allows files that can played natively to coexist with files that cannot in the TinyMCE views for playlists. There is a problem with the MediaElement plugin bridge that can't read the mejs from within the Silverlight plugin - probably because all of the JS runs in window.top

Gonna let this sit for a little bit while I continue to think about it.

#9 @wonderboymusic
6 years ago

In 28171:

Add a compatibility layer in wp-playlist.js to avoid VM errors from MediaElement's plugin bridge in the TinyMCE views for playlists by suppressing playback for files whose mime-type is not supported in the user's browser natively.

This is similar to how audio and video shortcodes are handled: file types are whitelisted for native playback.

See #27892.

#10 @wonderboymusic
6 years ago

  • Keywords commit fixed-major added

#11 @pavelevap
6 years ago

There are still problems:

Video_editor.jpg - still no preview.

Video_playlist_editor.jpg - still no preview, there is only new link "Download file".

#12 @wonderboymusic
6 years ago

That is on purpose - only files that can play in the browser natively are shown in the MCE views. All are shown on the front end and in the modal.

The problem is with TinyMCE being in an <iframe> and MediaElement loading its plugin bridge without access to window.top

#13 @pavelevap
6 years ago

OK, so .wmv file does not work. But it could be styled better? Now it looks like simple text URL (for video) and black preview (for video playlist). It would be nice to have black preview also for simple video, maybe with its title and notice "Sorry, preview is not available"?

And why in this case do not work poster images (I set up them for this video)? Also any limitation related to MCE views? Now it is very ugly and .wmv files are used frequently...

#14 @wonderboymusic
6 years ago

I promise you: if there was an easy fix, I would be all over it. This is probably going to require us to patch MediaElement upstream, which might not be in scope for 3.9.1

This ticket can remain open for now.

#15 @pavelevap
6 years ago

Sorry, I believe you :-)

Or we can create new ticket for 4.0, no problem.

#16 @nacin
6 years ago

In 28246:

Don't set the poster image for videos in a playlist if the image is the video mime-type icon blown up.

Merges [28158] to the 3.9 branch.

props wonderboymusic.
see #27892.

#17 @nacin
6 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 28247:

Add a compatibility layer in wp-playlist.js to avoid VM errors from MediaElement's plugin bridge in the TinyMCE views for playlists by suppressing playback for files whose mime-type is not supported in the user's browser natively.

Merges [28171] to the 3.9 branch.

props wonderboymusic.
fixes #27892.

Note: See TracTickets for help on using tickets.