WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#27895 closed defect (bug) (invalid)

TinyMCE Table plugin bug

Reported by: pixeltechnologies Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords:
Focuses: Cc:

Description

With a fresh install of WordPress 3.9 (tested with the nightly also) TinyMCE won't work with the table plugin.

The editor textarea is not even clickable, the toolbars are not loaded and the log contain : "Failed to load: http://xxx.com/wp-includes/js/tinymce/plugins/table/plugin.min.js "

The file does not exist on the server, the file name is actually "editor_plugin.js".

I've encountered this bug with a previous version (3.6 I think ?) but it was corrected with an update.

Change History (3)

#1 @ocean90
8 years ago

Are you using a custom plugin to handle tables in TinyMCE because WordPress doesn't include the TinyMCE plugin for tables.

#2 @azaozz
8 years ago

  • Keywords close added

There seems to be couple of things wrong with the WordPress plugin (or your theme's functions.php) that is trying to add the TinyMCE 'table' plugin:

  • It appears that the 'table' plugin is added with the tiny_mce_plugins filter, but as it is not part of WordPress, it needs to be added with mce_external_plugins.
  • It is adding the outdated version (3.x) of the 'table' plugin. In the new version the file name is plugin.min.js.

#3 @SergeyBiryukov
8 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

The plugin you're using needs to be updated for TinyMCE 4.0. Could not reproduce with TinyMCE Advanced.

See http://make.wordpress.org/core/2014/01/18/tinymce-4-0-is-in-core/.

Note: See TracTickets for help on using tickets.