WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#27921 closed defect (bug) (worksforme)

Had to click update twice from 3.9 (en_US) to 3.9 nb_NO

Reported by: knutsp Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.3
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

When updating the about 35 sites I mange for clients and friends, this happened on about 29 of them:

  1. Waited for automatic background updates (see below)
  2. Automatic background updates done form 3.8.3 (nb_NO) to 3.9 (en_US)
  3. Did manual (click) updates to 3.9 (nb_NO) on all sites after 24 hours
  4. All these sites still said a new version (3.9) was available
  5. Did manual update to 3.9 (nb_NO) for the second time
  6. Now ok.

The same thing, double updates for localized package, happened for 3.8.2 -> 3.8.3, but this third step has never happened before (many years of updating).

Most sites have PHP 5.4 or 5.5, ext/memcached, "Super Cache" plugin and "Advanced Automatic Updates" plugin with at least both core update options turned on. Most sites are single site, two are multisite.

I tried to reproduce by downgrading two sites to 3.8.3 (en_US) by FTP and manually upgrade to 3.9 (nb_NO), but then all went well on first pass.

Most, but not all, of the sites not affected by this runs under IIS with ext/wincache.

Related: #27669

Change History (5)

#1 @nacin
5 years ago

If I had to guess, this is either #27669 or #27164 or some unfortunate combination of both.

#2 @knutsp
5 years ago

The issue is still there, even on sites without any caching plugin.

  1. Advanced Automatic Updates takes care of update to 4.0, dashboard widget says so, but still there is a "new version available" as a button on the update-core.php and a nag on all admin pages.
  2. I manually update to 4.0-nb_NO, but still I'm nagged about a new version available
  3. I manually update to 4.0-nb_NO the second time (3 times including the automatic one) and this time there is no nag.

Step 1. to 2. happens on all sites (about 30), but not on some sites using Wincache
Step 3. happens on about 20 sites, the most of them have no persistent caching

There is no translations to update according to update-core.php

#4 @knutsp
4 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

No longer a problem.

#5 @netweb
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.