WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 8 months ago

#27932 closed enhancement (duplicate)

Image Editor Missing Features

Reported by: Ipstenu Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Media Keywords:
Focuses: Cc:

Description

The following changes to the media editor are highly noticed:

  • Missing border/padding options
  • Missing percent resizing
  • Missing image-size notice on resize (when you in-line scale an image in visual editor, it used to show how big the image was)
  • Missing 'title' in images so there's no text on hover

If I had to pick the most noticed, it's that very first one. A LOT of people apparently rely on it to pad images in situ, rather than having a theme handle it properly. We do have a plugin that handles those two:

http://wordpress.org/plugins/advanced-image-styles/

Here's a small selection of complaints in the forums, including .com :/

http://en.forums.wordpress.com/topic/image-resize-1
https://wordpress.org/support/topic/add-border-to-image-1
https://wordpress.org/support/topic/39-update-how-to-add-padding-and-border-to-images-now
https://wordpress.org/support/topic/the-wp-media-manager-is-absolutely-terrible
https://wordpress.org/support/topic/yo-bring-back-old-image-attributes
https://wordpress.org/support/topic/image-attributes-borders-padding-link-title
https://wordpress.org/support/topic/add-the-paddingmargin-feature-back-to-images

This was also noted by people at Meetups where 3.9 was demo'd

https://twitter.com/rachelbaker/status/456999788966203392

I know trac isn't the place to discuss, but this appears to be a bit larger than I initially thought. It's very much a noticed and missed feature for numerous people.

https://core.trac.wordpress.org/ticket/27366#comment:27

Change History (23)

comment:1 @SergeyBiryukov12 months ago

Missing image-size notice on resize (when you in-line scale an image in visual editor, it used to show how big the image was)

Related: #27941

comment:2 follow-up: @karelles12 months ago

Also the ability to change the source of the image in the Advanced section. And the field that displays the CSS you've created by filling in the fields, that you can edit easily.

Last edited 12 months ago by karelles (previous) (diff)

comment:3 @nacin12 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Border/margin was discussed in #27706 and extensively in IRC before being pushed into a plugin.

#27941 covers the size-on-resize notice.

"Missing percent resizing" — I don't see us bringing this back in the same form, it was a pretty bad experience.

"Missing 'title' in images so there's no text on hover" — best I can tell, there was no functionality change here in 3.9. See #18984 for the last time anything changed.

Rather than linking to unanswered support threads like this one, let's answer them. I would go with:

  • "There was no functionality change with title attributes; you can still add them."
  • "While percent-resizing is gone you can simply scale the image in the editor, something we'd like to make even better in the future."
  • "If your theme doesn't adequately handle border and padding for you, please try this plugin: http://wordpress.org/plugins/advanced-image-styles/."
  • "Thanks for pointing out that missing notice when you're resizing an image. We're tracking that in https://core.trac.wordpress.org/ticket/27941."
  • "If you'd like to edit the image source, please use the text editor."

I'm closing this out as it's a catch-all ticket and we have more specific tickets for all of these issues.

The image source could (*could*) come back for images inserted via "Insert from URL" but that should happen in a new ticket.

comment:4 in reply to: ↑ 2 @nacin12 months ago

  • Resolution changed from invalid to duplicate

Replying to karelles:

Also the ability to change the source of the image in the Advanced section. And the field that displays the CSS you've created by filling in the fields, that you can edit easily.

Just wanted to thank you karelles for the simple, straightforward comment here. The support moderators who would otherwise respond to a post like this one would probably appreciate similar measured tones in the forums.

comment:5 @sunflowermom12 months ago

Has anyone said yet that there doesn't appear to be any way to edit images at all...I need to make images left or right with the text aligned opposite, and I don't see any way to do that anymore. ---EDIT: OK, I just pasted and it actually did it to the right of the image, like I wanted it...but I have no idea why it did that...when I click on the image there's no options at all anymore, so I have no idea where to look for these features...

Also cannot seem to do anything with existing galleries...I'm trying to add images to a client's gallery, and there's no way to do it that I can see. Is gallery a separate issue? It's images, so I wasn't sure.

Last edited 12 months ago by sunflowermom (previous) (diff)

comment:6 follow-up: @Ipstenu12 months ago

@sunflowermom - You can still edit images.

When you insert images, you get the same picker for location we've had for a while: https://cloudup.com/cTKRvh0Q4wu

When you click on an image in the visual editor, it has a white pencil on a black background. Click that to edit and you get this: https://cloudup.com/c9XCllK9UPp

With galleries, again, click on the edit icon (pencil) and there's an 'Add to Gallery' link on the left side. Click that and add :)

If that's not working for you, you should post in the support forums: https://wordpress.org/support/

comment:7 in reply to: ↑ 6 @sunflowermom12 months ago

Thank you! I just discovered I can edit when I'm inserting the image...I see what you mean there...but I don't get a pencil. I get nothing when I hover or click on a gallery or image. So I cannot edit existing images and galleries. I guess I'll have to head to the support forums, as you suggested.

Thank you!

Replying to Ipstenu:

@sunflowermom - You can still edit images.

When you insert images, you get the same picker for location we've had for a while: https://cloudup.com/cTKRvh0Q4wu

When you click on an image in the visual editor, it has a white pencil on a black background. Click that to edit and you get this: https://cloudup.com/c9XCllK9UPp

With galleries, again, click on the edit icon (pencil) and there's an 'Add to Gallery' link on the left side. Click that and add :)

If that's not working for you, you should post in the support forums: https://wordpress.org/support/

comment:8 follow-up: @davidsorensen12 months ago

  • Severity changed from normal to critical
  • Type changed from enhancement to defect (bug)

If there is anything important to a good looking blog, besides the text, it is the way images are handled.

Limiting the most basic functions and forcing us to use yet another plugin to get these basic functions back is way beyond stupid.

WP is a tremendous gift to all of us, don't turn the dream into a nightmare please ;-)

comment:9 @ocean9012 months ago

  • Severity changed from critical to normal
  • Type changed from defect (bug) to enhancement

comment:10 in reply to: ↑ 8 ; follow-ups: @knutsp12 months ago

Replying to davidsorensen:

Limiting the most basic functions and forcing us to use yet another plugin to get these basic functions back is way beyond stupid.

Many think that border and margin editing in the editor was a bug in the first place. It is for your theme to decide how images are styled.

Percentage resizing can be achieved using a calculator, so it's hardly a basic function.

WP is a tremendous gift to all of us, don't turn the dream into a nightmare please ;-)

Yes. Image handling has improved tremendously through the last versions.

Thanks to the easy way to install plugins, almost everything is possible. Having many small plugins is not a problem. The quality of a plugin matters.

comment:11 in reply to: ↑ 10 @dsl22512 months ago

Replying to knutsp:

Many think that border and margin editing in the editor was a bug in the first place. It is for your theme to decide how images are styled.

What a strange idea! Do you really think that a theme can decide how images are styled globally and sitewide in a 100+ pages website that may include galleries, pages with different sorts of images among them and different kinds of sections that all have different layouts? Wow!

And what about texts? Why, in that case, themes should not decide how texts are styled? Why images should have a different approach that texts?

The truth is that some themes do have images styling build in. But that mainly applies to post categories and post archives when listing blog posts. That's fine. But I've never seen a theme offering build in image styling for images you insert from the Media Library. Where have you seen that?

comment:12 in reply to: ↑ 10 ; follow-ups: @davidsorensen12 months ago

"It is for your theme to decide how images are styled."

Sorry Knutsp, I believe wat you are saying here is very "unwise" to say it nice ;-) Please think about this.

I don't want to insult you because I know you probably mean well and think you are right, but what you are saying is really not very clever.

A theme is a BASIC startingpoint and in the theme the webmaster needs all the basic options there should be to work with it.

So please, rethink this, because we are CREATIVES not dumb copiers of standard themes. We want to work with images and do some creative stuff with it, without the need to add plugins for functions that are as basic as the sunlight by day.

Replying to knutsp:

Replying to davidsorensen:

Limiting the most basic functions and forcing us to use yet another plugin to get these basic functions back is way beyond stupid.

Many think that border and margin editing in the editor was a bug in the first place. It is for your theme to decide how images are styled.

Percentage resizing can be achieved using a calculator, so it's hardly a basic function.

WP is a tremendous gift to all of us, don't turn the dream into a nightmare please ;-)

Yes. Image handling has improved tremendously through the last versions.

Thanks to the easy way to install plugins, almost everything is possible. Having many small plugins is not a problem. The quality of a plugin matters.

comment:13 in reply to: ↑ 12 @knutsp12 months ago

Replying to davidsorensen:

So please, rethink this, because we are CREATIVES not dumb copiers of standard themes. We want to work with images and do some creative stuff with it, without the need to add plugins for functions that are as basic as the sunlight by day.

I am not talking about standard themes, but your theme and themes in general. If you are both creative and just a tiny bit clever, you are able to change the style of your theme so that it fits your needs. It will also save you a lot of work. Some plugins let you change the style without even touching a file or using local text/css editor.

See also http://wptavern.com/how-the-advanced-image-editing-properties-contributed-to-wordpress-theme-lock-in

comment:14 in reply to: ↑ 12 @Denis-de-Bernardy12 months ago

Replying to davidsorensen:

A theme is a BASIC startingpoint and in the theme the webmaster needs all the basic options there should be to work with it.

I beg to disagree here. Would you use inline styles in Word instead of document-level styles? I'll acknowledge many end-users who don't know better do, but if you're a creative type I'd respectfully imagine you don't. A CMS is no different.

A theme is where you define styles. If multiple image styles apply, then multiple CSS classes get defined. Or contextual styles within the stylesheet, whatever. Point here is, the most I'd expect from a CMS is the ability to specify a class. Preferrably amongst choices defined by the theme, and ideally amongst portable ones that are supported by multiple themes because WP suggests defining them. (Feel free to open a seperate ticket requesting that, btw; I'd wager it'll get more traction.)

Imho, the CMS should not be encouraging the use of inline styles, be them image borders or text colors (or font sizes or text aligns for that matter) beyond the likes of bold or italic. As such invalid, wontfix or plugin material all seem, to me, like correct ways to deal with the going matter.

Percent resize is a separate issue which I recollect is covered in a separate ticket. Anything beyond that is, imho, nothing but past UI clunkiness. Good riddance I say.

comment:15 follow-up: @dsl22512 months ago

I think we have here, since this issue appeared, a HUGE gap between techies and creative users.

The first group never use such features themselves but think they should teach the second group how to make use of them, while the second group just wants to make things work - fast, easy and straight forward.

We are not close to a mutual understanding I think...

comment:16 in reply to: ↑ 15 @davidsorensen12 months ago

Exactly!

Replying to dsl225:

I think we have here, since this issue appeared, a HUGE gap between techies and creative users.

The first group never use such features themselves but think they should teach the second group how to make use of them, while the second group just wants to make things work - fast, easy and straight forward.

We are not close to a mutual understanding I think...

comment:17 @rowanwolf12 months ago

  • Keywords needs-patch added
  • Resolution duplicate deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened

If you want users to put styles in the CSS file instead of editing images within WP, then give directions on how to do that. Removing the margins is a pain in the butt for me personally. I have been ticked that they can't be set -like the left/right/center image placement.

For me, this is a major issue as I have to deal with images multiple times a day. For me, the 3.8 image editor work very well.

I agree with dsl225

comment:18 @ocean9012 months ago

  • Keywords close added
  • Severity changed from major to normal

rowanwolf, what's wrong with the plugin mentioned in comment:3?

Currently it doesn't make sense to play the reopen-close game. This ticket is a duplicate of multiple tickets.

comment:19 @Denis-de-Bernardy12 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #27706.

Per nacin's comment further up:

https://core.trac.wordpress.org/ticket/27932#comment:3

comment:20 @rowanwolf12 months ago

Yes, folks can get the plug-in (and I did). However, why should folks have to get a plug-in for functionality that was an integrated part of WP?

What about those unfamiliar with WP or plug-ins (or technically uncomfortable)? I am neither, and came looking for an answer to why a basic function had been removed from the program. I did not go first to plug-ins. I assumed that something was wrong. From my perspective it still is.

Further, part of the argument above was that there was an effort to cut down "in-line coding." Well the plug-in does exactly that - put in in-line coding. So what is the point in removing a basic function if there is an expectation that folks will go grab a plug-in to do what was done as an integrated feature.

That's just my two cents, but it is frustrating.

comment:21 @SergeyBiryukov11 months ago

#28269 was marked as a duplicate.

comment:22 @ReneODeay8 months ago

  • Resolution duplicate deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened

It isn't just the ability to edit borders and margins and size of images, it is that all my images in the old posts/pages have changed since the update to 3.9.2..... some now have borders and some do not, doesn't seem to be any reason for the changes.
just about impossible to edit the images and text positions either. they don't stay where they are supposed to in new or old posts.
GADS I hate these updates.
And no, I do not want to have to add another plugin, that probably will monetize in the future.

comment:23 @ocean908 months ago

  • Keywords needs-patch close removed
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from reopened to closed

it is that all my images in the old posts/pages have changed since the update to 3.9.2.....

If ithis is a real issue, it should be in his own ticket.

And no, I do not want to have to add another plugin, that probably will monetize in the future.

Then just copy it and make your own of it, but I'm sure it will not monetize in the future.

Note: See TracTickets for help on using tickets.