WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#27953 closed defect (bug) (duplicate)

Dashboard welcome box links have hover on whole area, rather it should be only on text

Reported by: Ankit K Gupta Owned by: johnbillion
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Administration Keywords: has-patch
Focuses: ui Cc:

Description

On Dashboard, The hover effect is displaying in the whole line. It should show only on text.

E.g. Link of 'Get Started' have hover only on text but links of 'Next Steps' & 'More Actions' have links in the whole line.

Attachments (2)

Dashboard.png (47.1 KB) - added by Ankit K Gupta 5 years ago.
Hover bug ( welcome screen )
dashboard_css.patch (357 bytes) - added by Ankit K Gupta 5 years ago.
CSS fix for hover bug

Download all attachments as: .zip

Change History (15)

@Ankit K Gupta
5 years ago

Hover bug ( welcome screen )

@Ankit K Gupta
5 years ago

CSS fix for hover bug

#1 @Ankit K Gupta
5 years ago

  • Keywords has-patch added

#2 @helen
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Same comment as your other ticket, #28086 - why do you consider this a bug?

Why should this be restricted to the text alone? Seems like having a larger target is good for accessibility, and it doesn't appear to be interfering with any other elements.

#3 follow-up: @chiragswadia
5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

@Helen
If larger hover area is good for accessibility, then why that same behaviour is not used for "change your theme completely" link ?

I guess all the links should have the same hover effects and same hover area. I agree with @Ankit and I think this is a bug.

#4 in reply to: ↑ 3 ; follow-up: @SergeyBiryukov
5 years ago

Replying to chiragswadia:

If larger hover area is good for accessibility, then why that same behaviour is not used for "change your theme completely" link ?

The difference is that in "Next Steps" section each list item is a link, while in "Get Started" the link only refers to those exact words, "change your theme completely". The same applies to "Manage widgets or menus".

#5 in reply to: ↑ 4 @chiragswadia
5 years ago

Replying to SergeyBiryukov:

Thanks for the clarification. But since these are normal links and not buttons, It looks weird if I see cursor as pointer in blank white area.

If those links would have some kind of light border or background, then it would not look weird.

#6 @chiragswadia
5 years ago

  • Keywords ui-feedback added

#7 @SergeyBiryukov
5 years ago

  • Milestone set to Awaiting Review

#8 @codersaiful
5 years ago

Thanks for clearing on this concept. I appreciate this.

#9 @johnbillion
5 years ago

  • Owner set to johnbillion
  • Resolution set to fixed
  • Status changed from reopened to closed

In 29983:

Add a focus outline to the widget control toggle arrows. Fixes #27953. Props TomHarrigan.

#10 @johnbillion
5 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Wrong ticket. #27593.

Last edited 5 years ago by johnbillion (previous) (diff)

#11 @afercia
4 years ago

  • Keywords close added

Would propose to close this ticket, see #32288 (split out from #29897)

#12 @afercia
4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Closing this because fixed in #32288 feel free to reopen if you notice something was missed.

#13 @ocean90
4 years ago

  • Keywords ui-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution changed from fixed to duplicate

Duplicate of #32288.

Note: See TracTickets for help on using tickets.