WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27995 closed defect (bug) (invalid)

Media editor image scaling function inoperative

Reported by: LanzaRomanza Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords:
Focuses: Cc:

Description

I can add images to my new posts or pages under WP 3.9 but am unable to scale them from within the editor in any way. I do not want to re-scale in the library! Only the image once it's in my page/post. I use the "Wordpress Flickr Embed" plug-in but the scaling will not work with Flickr embedded photos or media library images. I have also deactivated the plug-in and the results are the same... no go.
I'm running the Suffusion theme.

In previous WP versions, the photo to be scaled in the post/page would be clicked and an editor would open with the image surrounded by text. The image could then be scaled up or down a certain number of percentage points - worked great! Now I'm dead in the water.

Attachments (2)

27995.mov (4.7 MB) - added by ericlewis 7 years ago.
screencast showing inability to reproduce bug
WP Media Resize.mp4 (4.1 MB) - added by LanzaRomanza 7 years ago.
Here is a screencast of the issue. Recording done on the HP Mini under Linux Mint 16. Firefox broswer..

Change History (15)

#1 @LanzaRomanza
7 years ago

Note I am using Google Chrome as my browser.

I also tried using Explorer and the results are a little different: I can copy and move the image in Explorer. And I can also click on a photo and get scaling bars to appear around the image. However, any attempt to scale, even in IE, is not working.

#2 @LanzaRomanza
7 years ago

Inability to resize photos in the editor is still busted in version 3.9.1. Also cannot delete a photo with the 'X' in the post editor.
The inability to delete a photo was also in version 3.9.0.

#3 follow-up: @ericlewis
7 years ago

Hi Lanza,

I downloaded the plugin and inserted the image and am able to resize. I'll attach a video showing my experience. Let me know if this helps shed light on the issue, or if you have more to add to the bug report.

@ericlewis
7 years ago

screencast showing inability to reproduce bug

#4 @ericlewis
7 years ago

  • Keywords close reporter-feedback added

#5 in reply to: ↑ 3 @LanzaRomanza
7 years ago

  • Keywords close reporter-feedback removed

Replying to ericlewis:

Hi Lanza,

I downloaded the plugin and inserted the image and am able to resize. I'll attach a video showing my experience. Let me know if this helps shed light on the issue, or if you have more to add to the bug report.

Hello,
I am aware how the resizing operation is intended to work. Thank you for the video. Point is, my editor does not allow any resize operation since WP 3.9. If I click on an inserted photo, only an edit and delete box appear and there are no arrows or anything else allowing resize. This is true for Flickr photos or photos inserted from my local media library. Please let me know how I may be able to provide additional information as clearly our experiences are not the same!

#6 follow-up: @ericlewis
7 years ago

  • Keywords reporter-feedback added

You mentioned you're using Google Chrome, what version? What OS are you running?

#7 in reply to: ↑ 6 @LanzaRomanza
7 years ago

  • Keywords reporter-feedback removed

Replying to ericlewis:

You mentioned you're using Google Chrome, what version? What OS are you running?

On my desktop: Browsers - Google Chrome 34.0.1847.137 M

Internet Explorer 8.0.6001.18702IC

OS - Windows XP Home Edition 5.1.2600 Service Pack 3 Build 2600

As far as I know, these are all the latest releases.

I also tried the edit function on my travel computer with the same results previously mentioned.
My travel PC info:

Hardware - HP Mini 1000
Browser - Monzilla Firefox 29.0+1-0utbunt0.13.10.3
OS - Linux Mint 16 with Cinnamon desktop

Lanza

#8 follow-ups: @ericlewis
7 years ago

  • Component changed from Media to TinyMCE

@LanzaRomanza, if you could make a screencast showing the issue, that would be great.

Can anyone can confirm/deny this bug on Windows XP with IE8 or Chrome?

@LanzaRomanza
7 years ago

Here is a screencast of the issue. Recording done on the HP Mini under Linux Mint 16. Firefox broswer..

#9 in reply to: ↑ 8 @LanzaRomanza
7 years ago

Replying to ericlewis:

@LanzaRomanza, if you could make a screencast showing the issue, that would be great.

Can anyone can confirm/deny this bug on Windows XP with IE8 or Chrome?

screencast attached.

#10 in reply to: ↑ 8 @SergeyBiryukov
7 years ago

Replying to ericlewis:

Can anyone can confirm/deny this bug on Windows XP with IE8 or Chrome?

Image resizing in TinyMCE works as expected for me on Windows XP in both Chrome and IE8.

Replying to LanzaRomanza:

Point is, my editor does not allow any resize operation since WP 3.9. If I click on an inserted photo, only an edit and delete box appear and there are no arrows or anything else allowing resize.

  1. Does it still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?
  2. Are there any JavaScript errors in your browser?

#11 follow-up: @azaozz
7 years ago

  • Keywords reporter-feedback added

Resizing works as expected in XP/IE8 and even in IE7 here too.

@LanzaRomanza from your screencast I see you're using several TinyMCE plugins. Perhaps one of them is disabling object_resizing in TinyMCE?

#12 in reply to: ↑ 11 @LanzaRomanza
7 years ago

  • Component changed from TinyMCE to Plugins
  • Keywords reporter-feedback removed

Replying to azaozz:

Resizing works as expected in XP/IE8 and even in IE7 here too.

@LanzaRomanza from your screencast I see you're using several TinyMCE plugins. Perhaps one of them is disabling object_resizing in TinyMCE?

@ericlewis and @SergeyBiryukov
Sorry for not reporting sooner... Memorial Day festivities.
Thanks everyone for all your input and suggestions. I have successfully narrowed this fault to a specific culprit. The plugin mb.miniAudioPlayer is causing this issue. I initially had version 1.4.5 installed and when deactivated, image scaling became operational. I upgraded the plugin to the latest revision (1.5.5), reactivated the plugin and the resize would not function. Going into the plugin settings I unchecked the default "Activate the Player customizer in the Post Editor" and that did the trick. I now have the plugin active and my image resizing works properly in the WP editor.
Interesting in that I have this plugin but I don't have a single post that has an audio file. In other words, I'm not actively using it.
Changing component setting from "TinyMCE" to "plugins".

#13 @SergeyBiryukov
7 years ago

  • Component changed from Plugins to TinyMCE
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.