WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#28010 closed defect (bug) (fixed)

RTL issue on media "Attach" screen

Reported by: ramiy Owned by: ocean90
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.9
Component: Media Keywords: has-patch
Focuses: rtl Cc:

Description

On the Media Library screen, we have the "Uploaded to" column, and if the file is not attached to any post/page, we can click the "Attach" link and attach the file to some post/page.

Clicking the link opens an iframe. This iframe have some issues in RTL mode, i see horizontal scroll, it wasn't there before.

Attachments (2)

Screenshot 2014-04-24 12.28.36.png (31.1 KB) - added by ramiy 7 years ago.
28010.patch (442 bytes) - added by SergeyBiryukov 7 years ago.

Download all attachments as: .zip

Change History (10)

#1 @5um17
7 years ago

I am also able to reproduce this issue. It is only in webkit browsers, i am not getting why webkit browsers behaving like this only when document is rtl.

#2 @SergeyBiryukov
7 years ago

  • Component changed from General to Media
  • Milestone changed from Awaiting Review to 4.0

The issue is similar to the one in #27629. Looks like Chrome reserves space for the scrollbar twice in RTL.

28010.patch fixes the main issue for me. It does not fix jumping of the search input on initial load. Any ideas how to fix that are welcome.

#3 @wonderboymusic
6 years ago

  • Keywords has-patch added

#4 @DrewAPicture
6 years ago

@SergeyBiryukov: What's left here? Can we at least partially fix the problem in lieu of a complete solution?

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.


6 years ago

#6 @ramiy
6 years ago

Patch tested, problem solved.

#7 @ocean90
6 years ago

Not sure, but 28010.patch does nothing for me.

#8 @ocean90
6 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 29353:

RTL: Fix media attach modal alignment.

props SergeyBiryukov.
fixes #28010.

Note: See TracTickets for help on using tickets.