Make WordPress Core

Opened 10 years ago

Closed 9 years ago

#28029 closed defect (bug) (invalid)

data-attributes (and css) removed for users with Author role

Reported by: yurig's profile yurig Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7
Component: Editor Keywords:
Focuses: Cc:

Description

When using the standard WordPress editor (TinyMCE) the HTML data-attributes are removed from the HTML upon saving when the user role is Author.
data-attributes are instead preserved when the user role is Administrator.

Some css style properties are also removed from inline style attributes, like for example 'position', 'left', 'top'. Again, they are preserved for Administrators.

data-attributes and css styles are not removed when switching between Visual and Text modes in the editor, but only when publishing the post/page.

First version tested with the problem is WordPress 3.7, still existing in 3.9.

Change History (3)

#1 @SergeyBiryukov
10 years ago

  • Keywords close added

Only Administrators and Editors have the unfiltered_html capability by default.

#2 @iseulde
9 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted

See above comment.

#3 @iseulde
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.