WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#28046 closed defect (bug) (fixed)

Customizer: Header image disappears after removing background image

Reported by: andrezrv Owned by: nacin
Milestone: 3.9.1 Priority: normal
Severity: normal Version: 3.9
Component: Customize Keywords: has-patch commit
Focuses: Cc:

Description

Steps to reproduce:

  1. Activate a theme with both custom header and custom background support.
  2. Use the customizer to set a header image and a background image.
  3. Use the customizer to remove the background image.

Since 3.9 the header image gets removed, but only using the customizer. If the background image is removed from Appearance > Background, the header image remains in place. I also noticed this keeps happening in trunk.

I checked with 3.8.3, 3.8.2 and 3.8, and everything seems to work fine there.

Attachments (1)

28046.1.diff (608 bytes) - added by danielbachhuber 6 years ago.
More targeted selectors for header controls

Download all attachments as: .zip

Change History (13)

#1 follow-up: @danielbachhuber
6 years ago

  • Keywords commit added

Thanks for the report, andrezrv. I've confirmed with TwentyFourteen in trunk.

@danielbachhuber
6 years ago

More targeted selectors for header controls

#2 @danielbachhuber
6 years ago

  • Keywords has-patch added; commit removed

#3 @danielbachhuber
6 years ago

  • Milestone changed from Awaiting Review to 3.9.1

#4 @ocean90
6 years ago

Related: #27848

#5 in reply to: ↑ 1 ; follow-up: @andrezrv
6 years ago

Replying to danielbachhuber:

Thanks for the report, andrezrv. I've confirmed with TwentyFourteen in trunk.

You're welcome :) This is my first ticket and I was feeling like a fifteen year old fangirl here.

#6 in reply to: ↑ 5 @nacin
6 years ago

  • Keywords commit added

Replying to andrezrv:

You're welcome :) This is my first ticket and I was feeling like a fifteen year old fangirl here.

This was a perfect bug report, thank you!

This is the same fix as #27848. Maybe we should sync up the selectors.

#7 @nacin
6 years ago

I'm going to use the ID as used in #27848. Ideally no IDs get used in views, but "#customize-control-header_image" is already specifically referred to in CSS and JS, and the class isn't.

#8 @nacin
6 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 28269:

Customizer: Only tie header button action events to the header controls.

props danielbachhuber.
fixes #28046. see #27848.

#9 follow-up: @nacin
6 years ago

In 28270:

Customizer: Only tie header button action events to the header controls.

Merges [28269] to the 3.9 branch.

props danielbachhuber.
fixes #28046. see #27848.

#10 in reply to: ↑ 9 ; follow-up: @Anariel Design
6 years ago

Hi Nacin,

just to ask if problem is fixed because i am still experiencing the same issue with the WordPress 3.9 and Customizer. Remove image feature for the background and also for the logo, removes also the header image.

Thanks,
Ana

Replying to nacin:

In 28270:

Customizer: Only tie header button action events to the header controls.

Merges [28269] to the 3.9 branch.

props danielbachhuber.
fixes #28046. see #27848.

#11 in reply to: ↑ 10 ; follow-up: @ocean90
6 years ago

Replying to Anariel Design:
Yes it's fixed, but 3.9.1 is not released yet, see http://make.wordpress.org/core/2014/05/06/release-candidate-for-3-9-1/

#12 in reply to: ↑ 11 @Anariel Design
6 years ago

Replying to ocean90:

Replying to Anariel Design:
Yes it's fixed, but 3.9.1 is not released yet, see http://make.wordpress.org/core/2014/05/06/release-candidate-for-3-9-1/

Thanks a lot :)

Note: See TracTickets for help on using tickets.