WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#28054 closed defect (bug) (invalid)

Plugin update

Reported by: bobz Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.9
Component: Plugins Keywords:
Focuses: Cc:

Description

Well it's bugging me so I need to report this.

Thing is, if you delete 'Hello Dolly' plugin from your WP installation, WP will always show you that you have 1 plugin to update, even if there are no plugin updates available.
It is silly I know, delete plugin, click few times around and the badge will show up.
This is like this for some time, not sure how long at least few months.

Change History (3)

#1 @nacin
6 years ago

Hi bobz, I can't reproduce this. Next time you see this, could you give us the value of:

var_dump( get_site_transient( 'update_plugins' ), wp_get_update_data() );

#2 @bobz
6 years ago

  • Resolution set to invalid
  • Severity changed from normal to trivial
  • Status changed from new to closed

Hi Nacin,

Thanks for reply.
Here is print_r, little bit better formatted then var_dump: http://pastebin.com/HdrnjYrW
Now I see what is the 'problem', plugin in a response is not installed as a plugin but is included in functions php.
Some plugins that are needed for theme to work correctly I don't install usual way but include them in theme files.

Anyway, it's not a bug it's a feature :P
http://community.spiceworks.com/shared/post/0000/4674/bug_vs_feature.gif

BR
Vlado

#3 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.