WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#28056 closed defect (bug) (invalid)

Problem with Hebrew comments

Reported by: mirono Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.3
Component: Comments Keywords:
Focuses: Cc:

Description

Hello,

Hebrew comments are aligned to the left instead to the right (RTL). It does not related to a theme or a plugin, and it misaligned in the admin panel as well.

It is the same as #17331 reported as fixed.

Thanks,
Miron.

Change History (7)

#1 follow-up: @SergeyBiryukov
7 years ago

  • Keywords reporter-feedback added

Could you provide a screenshot of the issue or the steps to reproduce it on a clean install to help us understand it better? I could not reproduce it on a Hebrew install.

#2 in reply to: ↑ 1 @mirono
7 years ago

Replying to SergeyBiryukov:

Could you provide a screenshot of the issue or the steps to reproduce it on a clean install to help us understand it better? I could not reproduce it on a Hebrew install.

Unfortunately, I can't provide the problem on a clean install, but you can see it in action in my blog here:
http://blogsh.ophir.org.il/?p=514#comments

I can also assure you that in the admin dashboard it looks right aligned as it should be.

#3 follow-up: @SergeyBiryukov
7 years ago

  • Keywords close added; reporter-feedback removed

You still have wp-content/languages/he_IL.php file from an older install on your site. Related: #20974.

The issue is caused by comment_direction class from that file:
https://i18n.trac.wordpress.org/browser/he_IL/tags/3.1.3/dist/wp-content/languages/he_IL.php#L32

Removing the file should resolve the issue. It does not exist in current Hebrew packages.

#4 in reply to: ↑ 3 @mirono
7 years ago

Replying to SergeyBiryukov:

You still have wp-content/languages/he_IL.php file from an older install on your site. Related: #20974.

The issue is caused by comment_direction class from that file:
https://i18n.trac.wordpress.org/browser/he_IL/tags/3.1.3/dist/wp-content/languages/he_IL.php#L32

Removing the file should resolve the issue. It does not exist in current Hebrew packages.

Renaming wp-content/languages/he_IL.php to wp-content/languages/he_IL.php.old didn't solve the problem.

#5 @SergeyBiryukov
7 years ago

You also have an old "Comment Direction" plugin that contains the same code. It should be deactivated.

#6 @mirono
7 years ago

Thanks, disabling the plugin fixed the problem.

#7 @SergeyBiryukov
7 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.