WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#28061 closed defect (bug) (duplicate)

Editing caption causes image to move location ("jump") in editor

Reported by: samuelsidler Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords:
Focuses: Cc:
PR Number:

Description

Steps to reproduce:

  1. Create a new post
  2. Using the "Add Media" button, add a new image
  3. Immediately add another image using the "Add Media" button
  4. Select the first (top) image so the "edit" icon appears on it.
  5. Click the edit icon.
  6. Add a caption and "Update" the image

The image will now move to the second (bottom) location. It should stay in its current location.

This appears to be a regression from 3.8.

Change History (6)

#1 follow-up: @iseulde
5 years ago

  • Component changed from Editor to TinyMCE

I can't reproduce this in trunk. What setting do the images have when you insert them? Are they aligned? Are they linked?

#2 in reply to: ↑ 1 @samuelsidler
5 years ago

Replying to avryl:

I can't reproduce this in trunk. What setting do the images have when you insert them? Are they aligned? Are they linked?

Looks like it's fixed on trunk, but I can definitely reproduce in 3.9. We should make sure whatever fixed this makes it onto the branch.

#3 @iseulde
5 years ago

Yep, me too now. [28190] fixed it.

#4 @iseulde
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

[28231] fixes this for 3.9.
But how do I close a ticket as fixed? :)

#5 @samuelsidler
5 years ago

  • Resolution changed from invalid to fixed

#6 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution changed from fixed to duplicate

Duplicate of #27922.

Note: See TracTickets for help on using tickets.