WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#28066 closed defect (bug) (worksforme)

Updating Page or Post after inserting Anchor causes Anchor to disappear

Reported by: jchambo Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Greetings,

Whenever I go to insert an anchor, the anchor inserts just fine. However, when I save the post or page, after the update, the anchor disappears, and I have to re-insert it every time I save or update the page / post.

This never happened with WordPress 3.8.3 but only after a 3.9 update.

Thanks.

Change History (4)

#1 follow-up: @SergeyBiryukov
5 years ago

Do you use name or id attribute for an anchor? Related: #24077.

#2 @idamyrussell
5 years ago

I am having this same problem! I can get 3 anchors to stay on my page, but if I add a 4th and update the page it might save the new one and delete an older one, or the new one just doesn't save.

I use the TinyMCE anchor button to insert anchors. Looking at the code, it uses name. When I insert the anchors in the code side using "name" the anchors stayed.

#3 in reply to: ↑ 1 @jchambo
5 years ago

Replying to SergeyBiryukov:

Do you use name or id attribute for an anchor? Related: #24077.

I'm not 100% sure because after I insert the Anchor, and click the "Text" editor instead of Visual, it disappears and never shows anything. Even when I switch back to Visual, it is gone.

#4 @azaozz
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Cannot reproduce this in trunk using the TinyMCE 'anchor' plugin. It inserts <a id="anchor-text"></a> and works as expected. Tested by inserting about 20 anchors in a long post. None was removed after saving or switching Visual -> Text and back.

Closing as worksforme, feel free to reopen if this still happens.

Note: See TracTickets for help on using tickets.