Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#28073 closed defect (bug) (fixed)

Negative number of plugins in left-side menu

Reported by: satri's profile Satri Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.9
Component: Administration Keywords: has-patch commit
Focuses: ui, administration Cc:

Description

In WordPress 3.9, I was invited to update a plugin, which I did, but ended up with "-1" plugin in the left-side WordPress menu.

See attached screenshot with the "-1" in red in the left-side column.

Cheers -- Alex

Attachments (2)

bug_negative-plugin-number_wp39.png (71.5 KB) - added by Satri 10 years ago.
Negative number of plugins screenshot
28073.patch (492 bytes) - added by SergeyBiryukov 10 years ago.

Download all attachments as: .zip

Change History (6)

@Satri
10 years ago

Negative number of plugins screenshot

#1 @jesin
10 years ago

I'm not able to reproduce it. I installed an earlier version of the same plugin and updated it.

http://i.imgur.com/18c2OLu.png

The number "1" shown next to Plugins is another plugin that needs updating.

I even tried this on an installation with no other plugins.

#2 @mordauk
10 years ago

I don't know how I made it happen but I have seen this happen at least once as well.

#3 @SergeyBiryukov
10 years ago

  • Keywords has-patch commit added
  • Milestone changed from Awaiting Review to 4.0

28073.patch fixes a copy/paste error in [27280].

#4 @SergeyBiryukov
10 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 28254:

Avoid displaying a negative number of plugin updates in admin menu.

fixes #28073.

Note: See TracTickets for help on using tickets.