Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#28076 closed enhancement (duplicate)

Problems deleting auto-generated thumbs if the custom size is removed from functions.php

Reported by: cokeyblokey's profile cokeyblokey Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Media Keywords:
Focuses: administration Cc:

Description

I was directed to the TRAC from here: https://wordpress.org/support/topic/a-word-of-warning-deleting-an-image-doesnt-delete-thumbs?replies=4

I have found that if a custom image size is removed from functions.php, then any image uploaded before that point, that is then deleted from the media library afterwards does not have those auto-generated sizes deleted too. Only image sizes that exist in functions.php are deleted.

It would be great to have all sized images deleted, regardless of the sizes that exist in functions.php

Change History (1)

#1 @SergeyBiryukov
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24518.

Note: See TracTickets for help on using tickets.