WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28082 closed defect (bug) (fixed)

Dismiss icon of welcome box missing in IE-8

Reported by: Ankit K Gupta Owned by: ocean90
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.8
Component: Help/About Keywords: has-patch commit
Focuses: ui, administration Cc:

Description

On Wordpress Dashboard, Dismiss icon missing in Internet Explorer-8. It should be display as other browsers.

Attachments (5)

Dismiss missing.png (8.5 KB) - added by Ankit K Gupta 6 years ago.
Screen shot of Welcome box in IE
dismiss-icon-ie8.diff (798 bytes) - added by andrezrv 6 years ago.
dismiss-icon-ie8-v2.diff (1.5 KB) - added by andrezrv 6 years ago.
28082.diff (1.6 KB) - added by DrewAPicture 6 years ago.
ie8_dismiss_with_patch.png (42.3 KB) - added by DrewAPicture 6 years ago.

Download all attachments as: .zip

Change History (15)

@Ankit K Gupta
6 years ago

Screen shot of Welcome box in IE

#1 @Ankit K Gupta
6 years ago

  • Keywords needs-patch added

#2 @ocean90
6 years ago

  • Component changed from Appearance to Help/About
  • Focuses administration added

#3 @andrezrv
6 years ago

  • Keywords has-patch 2nd-opinion added; needs-patch removed

This is caused by IE8 not supporting ::before and ::after pseudo-elements. Using just :before makes the icon visible, but the element needs to float to not break the line, and top margin needs to be adjusted to keep the same visual style.

#4 @iseulde
6 years ago

  • Keywords needs-refresh added; has-patch 2nd-opinion removed

Thank you for the report and patch. It looks like your patch moves the close icon for tags in the editor up, so this needs to be fixed. There are also a few more ::befores in dashboard.css.

#5 @iseulde
6 years ago

  • Version changed from 3.9 to 3.8

#6 @andrezrv
6 years ago

  • Keywords has-patch 2nd-opinion added; needs-refresh removed

Oh, I totally skipped those other selectors. I think the new patch fixes the issue, but it needs a second pair of eyes on it again.

Last edited 6 years ago by andrezrv (previous) (diff)

#7 @SergeyBiryukov
6 years ago

  • Milestone changed from Awaiting Review to 4.0

@DrewAPicture
6 years ago

#8 @DrewAPicture
6 years ago

  • Keywords commit added; 2nd-opinion removed

28082.diff regenerates the patch from root, which fixes the issue for me in IE8, see ie8_dismiss_with_patch.png.

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.


6 years ago

#10 @ocean90
6 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 29314:

IE8 doesn't support ::before and ::after pseudo-elements. Replace them with :before and :after.

props andrezrv, DrewAPicture, ocean90.
fixes #28082.

Note: See TracTickets for help on using tickets.