WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 7 months ago

#28084 closed defect (bug) (fixed)

Post and page permalink's text getting cut in Firefox.

Reported by: Ankit K Gupta Owned by: SergeyBiryukov
Milestone: 4.8 Priority: normal
Severity: normal Version: 3.9
Component: Posts, Post Types Keywords: has-patch has-ui-feedback good-first-bug commit
Focuses: ui, performance Cc:

Description

On edit page and post backend page, when we edit the permalink then character like g, q, y, j, u etc getting cut in text box from bottom of Firefox.

Attachments (7)

post permalink.png (41.5 KB) - added by Ankit K Gupta 3 years ago.
Screen shot of Post backend
page permalink.png (38.4 KB) - added by Ankit K Gupta 3 years ago.
Screen shot of Page backend
edit-rtl.css.patch (331 bytes) - added by Ankit K Gupta 3 years ago.
patch file
edit.css.patch (319 bytes) - added by Ankit K Gupta 3 years ago.
Updated patch file
page.png (23.1 KB) - added by Ankit K Gupta 12 months ago.
page-edit
post.png (33.3 KB) - added by Ankit K Gupta 12 months ago.
post-edit
28084.diff (337 bytes) - added by Presskopp 8 months ago.

Download all attachments as: .zip

Change History (25)

@Ankit K Gupta
3 years ago

Screen shot of Post backend

@Ankit K Gupta
3 years ago

Screen shot of Page backend

@Ankit K Gupta
3 years ago

patch file

#1 @Ankit K Gupta
3 years ago

  • Keywords has-patch added

@Ankit K Gupta
3 years ago

Updated patch file

#2 @DrewAPicture
3 years ago

  • Component changed from General to Posts, Post Types

#3 @joedolson
3 years ago

  • Focuses accessibility removed

#4 @Ankit K Gupta
2 years ago

  • Keywords ui-feedback ux-feedback added

#5 @karmatosed
12 months ago

Thanks for this @Ankit K Gupta, great catch!

As this fixes the visual issue, I would absolutely say this is a candidate for committing. However, I would be interested if we're ok increasing the height or need to adjust other elements to keep the design. Perhaps @melchoyce or @michaelarestad can give us some insight and if agree to commit, they can also do that for us.

#6 @melchoyce
12 months ago

I can't replicate this issue in Firefox 48.0 on OSX El Capitan. What browser version/OS are you using, @Ankit K Gupta?

#7 @Ankit K Gupta
12 months ago

@karmatosed Thanks for your kind words and reviewing this ticket!
@melchoyce I can see this on Firefox 48.0 Windows 7.
Please refer attached screenshot on windows 7.

@Ankit K Gupta
12 months ago

page-edit

@Ankit K Gupta
12 months ago

post-edit

#8 @Ankit K Gupta
12 months ago

  • Keywords ux-feedback removed

#9 @karmatosed
12 months ago

This does seem related to Windows. I can replicate using the latest version of Firefox and windows.

https://cldup.com/U-CxpfJani.png

#10 @karmatosed
8 months ago

  • Keywords good-first-bug added

#11 @karmatosed
8 months ago

  • Milestone changed from Awaiting Review to Future Release

#12 @Ankit K Gupta
8 months ago

@karmatosed Can we fix this in 4.8 ?

#13 @karmatosed
8 months ago

  • Focuses performance added

@Ankit K Gupta as there is no 4.8 released, this would be down to someone adding into a point release. We need a patch however before we can fix, if someone wants to work on one we can then get the eyes of a committer on this.

@Presskopp
8 months ago

#14 @Presskopp
8 months ago

@karmatosed There is a patch above!? However, I did a refresh. The issue is still to see in Firefox 50, and I think it's an easy and feasable patch. I was thinking about other places where we possibly should raise height to 24px but was unable to find one with a need.

#15 @Ankit K Gupta
8 months ago

@karmatosed Patch is already added for fixing this issue in Firefox. Also tested for Chrome. It's not creating issue on other browsers.

#16 @karmatosed
8 months ago

  • Keywords has-ui-feedback commit added; ui-feedback removed

My apologies, drove by and didn't catch up everything. Let's flag this for commit then and hopefully it gets into a point release.

#17 @SergeyBiryukov
7 months ago

  • Milestone changed from Future Release to 4.8

#18 @SergeyBiryukov
7 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 39905:

Posts, Post Types: Increase the height of post slug input to prevent certain characters from being cut in Firefox on Windows.

Props Ankit K Gupta, Presskopp.
Fixes #28084.

Note: See TracTickets for help on using tickets.