WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#28086 closed defect (bug) (duplicate)

Dismiss link covering a wide area on hover, hover effect should be only on text not on whole area.

Reported by: Ankit K Gupta Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Administration Keywords:
Focuses: ui, accessibility Cc:

Description

Dashboard welcome box having a dismiss link for hide the box, It have hover effect(cursor on hover)and covering wide area due to padding. Hover (cursor pointer)effect should only on text.

Attachments (4)

dismiss text.png (33.2 KB) - added by Ankit K Gupta 6 years ago.
Screen shot of dismiss text
dashboard-rtl.css.patch (655 bytes) - added by Ankit K Gupta 6 years ago.
patch file
dashboard.css.patch (643 bytes) - added by Ankit K Gupta 6 years ago.
Updated patch file
28086.diff (662 bytes) - added by MikeHansenMe 6 years ago.
More consistant padding and margin

Download all attachments as: .zip

Change History (11)

@Ankit K Gupta
6 years ago

Screen shot of dismiss text

@Ankit K Gupta
6 years ago

patch file

#1 @Ankit K Gupta
6 years ago

  • Keywords has-patch added

#2 @helen
6 years ago

  • Keywords reporter-feedback close added; has-patch removed

Why should this be restricted to the text alone? Seems like having a larger target is good for accessibility, and it doesn't appear to be interfering with any other elements.

Also, there is no need to patch RTL files - they are automatically created in the build process.

#3 @SergeyBiryukov
6 years ago

  • Component changed from Appearance to Administration

#4 @Ankit K Gupta
6 years ago

I agree with you that larger target is good for accessibility but user point of view, hover should take effect only on text or icon like others button/label/links of this CMS. Others elements having hover only on text.
On the others hand it should take same accessibility, means in this case hover effect covering only upper side of text. If larger accessibility is good then kept this effect same from top and bottom of the text
To make consistent behavior, this link should have margin instead of padding.

Version 0, edited 6 years ago by Ankit K Gupta (next)

@Ankit K Gupta
6 years ago

Updated patch file

@MikeHansenMe
6 years ago

More consistant padding and margin

#5 @afercia
5 years ago

See #32287 (split out from #29897)

#6 @afercia
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Going to close this, fixed in #32287. Feel free to reopen if you notice something was missed.

#7 @ocean90
5 years ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution changed from fixed to duplicate

Duplicate of #32287.

Note: See TracTickets for help on using tickets.