WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#28087 closed defect (bug) (duplicate)

TinyMCE paste includes style color

Reported by: Ipstenu Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords:
Focuses: Cc:

Description

When I copy and paste from a webpage, it puts in the colors. This sounds like it's fine, but it does it even if no color is specified in the html. So if I copy from a 'normal' page where CSS sets the color to black, I get this:

<p style="color: #000000;">....</p>

That causes unexpected results with regards to my theme design (like breaking blockquotes).

I tested on 3.9 and trunk, and then at http://www.tinymce.com/tryit/basic.php

On tinyMCE.com it does not force insert the color. This did not happen on 3.8.x

Attachments (1)

patch_commit_6cc586831f87.patch (666 bytes) - added by thomasvanderbeek 7 years ago.
Set paste_webkit_styles to 'none'

Download all attachments as: .zip

Change History (4)

#1 @Ipstenu
7 years ago

  • Component changed from General to TinyMCE

@thomasvanderbeek
7 years ago

Set paste_webkit_styles to 'none'

#3 @ocean90
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28016.

Note: See TracTickets for help on using tickets.