WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#28096 closed defect (bug) (fixed)

Insert/edit link: Ugly arrow position at "Or link to existing content"

Reported by: sergej.mueller Owned by: SergeyBiryukov
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.9
Component: Editor Keywords: has-patch
Focuses: ui Cc:

Description

http://i.imgur.com/9GYlc55.png
Before patch

http://i.imgur.com/VRC3LSp.png
After patch

Attachments (3)

css.patch (50.7 KB) - added by sergej.mueller 8 years ago.
28096.patch (394 bytes) - added by TobiasBg 8 years ago.
28096.2.patch (593 bytes) - added by iseulde 8 years ago.

Download all attachments as: .zip

Change History (14)

@sergej.mueller
8 years ago

#1 @iseulde
8 years ago

  • Type changed from enhancement to defect (bug)
  • Version changed from trunk to 3.9

There's no need to patch minified files, a post commit task takes care of that. :)

What browser are you using? For me the arrow looks okay, it's right in the middle.

#2 @iseulde
8 years ago

  • Keywords reporter-feedback added

#3 @TobiasBg
8 years ago

I also can't reproduce this in 3.9 or trunk, using Chrome.

#4 follow-up: @sergej.mueller
8 years ago

What browser are you using?

Safari & Firefox on Mac (Retina).

The patched version works fine in Safari, Chrome, FX.

#5 @sergej.mueller
8 years ago

  • Keywords has-patch added

#6 in reply to: ↑ 4 @iseulde
8 years ago

  • Keywords reporter-feedback removed

Ah, works fine for me on a non retina mac. Also tested on someone's retina iPad and there it works fine too. Can anyone else reproduce this?

Last edited 8 years ago by iseulde (previous) (diff)

#7 @TobiasBg
8 years ago

I can now reproduce this with Safari 7.0.3 on OS X 10.0.2 (non-retina), but not in Firefox 29 or Chrome 35 beta.

The position: absolute from the patch fixes it for me.

@TobiasBg
8 years ago

#8 @iseulde
8 years ago

Updated Safari from 7.0.2 to 7.0.3 and now I can reproduce this as well. Weird how a security update is causing this. Can't reproduce in Chrome 34.0.1847.131.

Last edited 8 years ago by iseulde (previous) (diff)

@iseulde
8 years ago

#9 @iseulde
8 years ago

The right way to fix this would be to add display: inline-block;, like all the other dashicons.

#10 @SergeyBiryukov
8 years ago

  • Milestone changed from Awaiting Review to 4.0

#11 @SergeyBiryukov
8 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 28236:

Fix arrow positioning in "Insert/edit link" modal.

props avryl, sergej.mueller.
fixes #28096.

Note: See TracTickets for help on using tickets.