WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 4 years ago

#28133 closed defect (bug) (worksforme)

Translation updates problems

Reported by: pavelevap Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: I18N Keywords:
Focuses: Cc:
PR Number:

Description

I made fresh English installation and change it to Czech language with some localization files (I did not copy theme localization files).

Updates page tells me, that "Some of your translations are out of date."

1) I would like to know which translations are available to update, because I want one theme in English and not update it. Or I made changes to localization files and do not want to update them. I want to select, what will be updated as it works for plugins and themes now.

2) There are no localization files for these themes, so they are not "out of date". They are simply missing and I would like to select if I want to download localization files or let it be in English.

I tried to test some other theme later, run installation and localization updates were also started (!). I did not want it, I want to let one theme in English and also made some changes to localization of other theme.

But nevermind, update failed :-) "The package could not be installed. The theme is missing the style.css stylesheet." Please see attached screenshot.

I have 5 default themes (latest trunk) and only 3 themes were trying to update localization itself. CSS files are available and not missing. I am not sure what is going on here? Is it somehow related to development version of WordPress (trunk)?

Attachments (1)

Updating_translations.jpg (96.1 KB) - added by pavelevap 6 years ago.

Download all attachments as: .zip

Change History (6)

#1 @SergeyBiryukov
6 years ago

  • Component changed from General to I18N

#2 @netweb
5 years ago

Related: #28571

#3 @chriscct7
4 years ago

  • Keywords needs-patch added

This ticket was mentioned in Slack in #core-i18n by ocean90. View the logs.


4 years ago

#5 @ocean90
4 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

1) Is a duplicate of #34907.

2) The string was changed in [31368].

Note: See TracTickets for help on using tickets.