WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#28143 closed defect (bug) (fixed)

Automated Theme Scanning Engine doesn't allow text "Template: " anywhere in the style.css body

Reported by: TomasM Owned by:
Milestone: WordPress.org Priority: normal
Severity: normal Version:
Component: WordPress.org Site Keywords: reporter-feedback
Focuses: template Cc:

Description

Hello, I cannot find exactly where to put this ticket, I hope you will add it to the appropriate section.

So, this bug is related to the theme scanning process. Recently I was trying to submit my theme and was getting strange error:

Results of Automated Theme Scanning: Pass

There is no theme called '*/' in the directory. For child themes, you must use a parent theme that already exists in the directory.

My theme is parent theme, so I spent couple of hrs trying to find out what is going on...

This error was caused by a comment in the middle of style.css:

/* Tip12 - Uncomment following CSS rules to have classic Twenty Twelve front page look - disable header image for the Front Page Template: */

Suggestion would be to look for the "Template:" only in the first commented section of the style.css.

Thank you!

Change History (5)

#1 @DrewAPicture
6 years ago

  • Focuses template added
  • Milestone changed from Awaiting Review to WordPress.org

#2 @DrewAPicture
6 years ago

  • Keywords reporter-feedback added

Hi Tomas,

Was this ever resolved?

#3 @SergeyBiryukov
6 years ago

  • Component changed from General to WordPress.org site

#4 @nacin
6 years ago

  • Component changed from WordPress.org site to General
  • Resolution set to fixed
  • Status changed from new to closed

Core isn't affected here, as get_file_data() is fairly intelligent. Some code on WordPress.org was out of date. This is now fixed.

#5 @SergeyBiryukov
6 years ago

  • Component changed from General to WordPress.org site
Note: See TracTickets for help on using tickets.