WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#28149 closed feature request (duplicate)

indication of possible conflicts in wp-admin dashboard

Reported by: Kniebremser Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Administration Keywords:
Focuses: Cc:

Description

In WordPress I miss a feature where I will permanently pointed to potential conflict situations.
Wordpress lives of themes and plugins, and the content of WordPress installations life of linked content.

my idea:
under wp-admin -> dashboard -> a new submenu "System Status"

There problems are displayed.
if the requirements for php and mysql for themes and plugins are not sufficient in my WP installation.

for example plugins: possible indicators

  • There are no known problems
  • The plugin "blabla" 4.0 is not authorized for WP. Only for WP 3.8
  • The plugin "blabla" requires php version 5.6. You're using 5.4.
  • The plugin "blabla" requires mysql-version 5.4. You are using 4.0.4

This could cause a lot of support requests in the various forums are avoided.

It should also be checked, the linked elements, if they are still available. If you have many linked elements lose, you very fast track.
And you can not check every link, if it is interrupted.

The whole is good material for a plugin. To insert it later in the core.

Change History (3)

#2 @anEffingChamp
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22056.

I think that Wordpress natively does a good job of announcing its software conflicts. While there is some value to publishing them all in a central resource like the dashboard, encouraging that level of technical understanding may also stand in conflict with the core principle of keeping Wordpress simple enough for most users to simply sit down, and write.

Last edited 7 years ago by anEffingChamp (previous) (diff)

#3 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.