WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28153 closed enhancement (duplicate)

Plugin list table Author and Plugin URI are external links and should open in new tab/window

Reported by: drrobotnik Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Plugins Keywords:
Focuses: accessibility, administration Cc:

Description

As these are always external links they should open in a new window.

Attachments (1)

class-wp-plugins-list-table.php.diff (1.3 KB) - added by drrobotnik 6 years ago.
add target="_blank" for external author and plugin URI links

Download all attachments as: .zip

Change History (3)

@drrobotnik
6 years ago

add target="_blank" for external author and plugin URI links

#1 @joedolson
6 years ago

From an accessibility perspective, this would be a bad choice. WordPress should not make that decision for people; they can open the links in a new window if they wish.

For accessibility, links should only be set to open in a new window if opening in the same window would disrupt a process (e.g., if the user needs help information while filling out a form).

#2 @SergeyBiryukov
6 years ago

  • Component changed from General to Plugins
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from trunk to 3.9

Duplicate of #20839.

Note: See TracTickets for help on using tickets.