WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#28157 closed defect (bug) (duplicate)

Using Email Address as username fails on Recovery Password

Reported by: xomero Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Users Keywords:
Focuses: administration Cc:
PR Number:

Description (last modified by SergeyBiryukov)

When you create an user with an Email address as username, let me say a@email.com and put b@email.com as User's Email Address, when you go to "Lost Password" it asks for "Username or E-mail", if you type a@email.com it will fail saying: "ERROR: There is no user registered with that email address." What it is technically true, but a@email.com it is an Username, so I must be allowed to Recover my Password.

The defect is that, if the username it looks like an email address, WordPress will only check if the string it is a registered email address in the Blog, is not checking if an user with an username like this exists.

Change History (2)

#1 @DrewAPicture
6 years ago

  • Focuses ui removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi xomero, thanks for the report!

Unfortunately, it looks like this is actually a duplicate of #22367, if you'd like to join the discussion over there.

#2 @SergeyBiryukov
6 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.