WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#28164 closed defect (bug) (duplicate)

Multisite (subfolders) causes 500 Internal Server Error on non-existing subfolders of wp-content, wp-admin and wp-includes

Reported by: Harold Angenent Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7.1
Component: Rewrite Rules Keywords:
Focuses: multisite Cc:

Description

When using Multisite (subfolder install), visiting /wp-content/not-a-folder/ returns a 500 Internal Server Error instead of a 404 Not Found.

Steps to reproduce

  • Install Multisite with subfolders. No plugins, default theme (twentyfourteen in my case)
  • Use the generated .htaccess
  • Visit <your-install>/wp-content/not-a-folder/

Expected

404 Not Found instead of 500 Internal Server Error

Additional information

  • <your-install>/wp-content/not-a-folder (without trailing slash) DOES return the 404, but doesn't show the theme / WordPress (just a plain Apache 404)
  • Error log reports too many redirects
  • The problem seems to be here: RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L], since it works properly without this line of code (as well as removing the question mark)

Setup

For this example I am using MAMP on my Mac, but I have seen this in the wild on several setups and servers (all Apache).
WP: 3.9 and below (lowest tested: 3.7.1)

Change History (3)

#1 @JPry
6 years ago

I'm able to reproduce this error on a production site running on a linux server.

Here is the error message reported in the error log:

[Sun Jun 08 18:01:16 2014] [error] [client 173.15.189.110] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
Last edited 6 years ago by JPry (previous) (diff)

#2 @erikalm
6 years ago

I am able to reproduce this on a multisite installed with subdomains (instead of subfolders). Same type of error as JPry.

This is on Wordpress 4.1...

I'm not sure if I should change the ticket so I'm leaving it at 3.7.1...

#3 @jeremyfelt
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this and #30588 as duplicates of #20746.

Note: See TracTickets for help on using tickets.