WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#28199 closed enhancement (fixed)

Improve upgrade translations verbiage

Reported by: netweb Owned by: SergeyBiryukov
Milestone: 4.2 Priority: normal
Severity: normal Version: 3.9.1
Component: Upgrade/Install Keywords: has-patch commit
Focuses: docs Cc:

Description

When new translations are available for a recently installed plugin the current notice displayed is:

Some of your translations are out of date.

Technically they are not out of date as they do not yet exist.

Suggested verbiage change to:
Some of your translations are out of date or translations are available for a recently installed plugin or theme.

Quite sure this would also be the case for wordpress.org authored themes or anything hosted on the WordPress GlotPress at http://translate.wordpress.org/projects

Attachments (3)

28199.patch (776 bytes) - added by netweb 7 years ago.
28199.diff (2.4 KB) - added by DrewAPicture 6 years ago.
28199.2.diff (697 bytes) - added by DrewAPicture 6 years ago.

Download all attachments as: .zip

Change History (20)

@netweb
7 years ago

#1 @DrewAPicture
7 years ago

  • Keywords dev-feedback has-patch added
  • Milestone changed from Awaiting Review to 4.0

Would also be nice to get dev feedback here in addition to docs feedback.

#2 follow-up: @adiant
7 years ago

At Drew's suggestion, I offer:
"New translation(s) are available for recently installed plugin(s) or theme(s)."

Last edited 7 years ago by adiant (previous) (diff)

#3 @michaelbeil
7 years ago

I like @adiant's phrasing the best.

#5 @SergeyBiryukov
7 years ago

  • Summary changed from Imporove upgrade translations verbiage to Improve upgrade translations verbiage

#6 in reply to: ↑ 2 @netweb
7 years ago

Replying to adiant:

At Drew's suggestion, I offer:
"New translation(s) are available for recently installed plugin(s) or theme(s)."

New translations can be offered for existing plugins and/or themes, this string is not explicitly meant for 'new plugins/themes' and needs to also account for existing plugins/themes.

"Translations update(s) are available for existing or recently installed plugin(s) or theme(s)."

#7 @nacin
7 years ago

"Some of your translations are out of date." was designed to be simple and succinct. Keep in mind that until now, the plugin or theme simply had an update notice and the languages got updated with each update. The user shouldn't need to know what's going on; it should all "just work". I was going for keeping it super simple.

These proposals are way more complex than we need. I'd suggest, at most, something like a "Details" link that expands and reveals the actual updates (or installs) to be performed. But we don't want a user to need to cherry-pick translations, or avoid updating their translations because of one that they don't like. In this case, we probably know better.

#8 @adiant
7 years ago

With the additional information provided by netweb, if a simple message rewrite is still of interest after nacin's explanation, I would suggest "New plugin/theme translation(s) are available."

#9 @siobhan
7 years ago

I agree that we should aim for simplicity. Saying it could be this one thing or this other thing is confusing.

Rather than bamboozling the user with information, we should keep in mind the action we want them to take - update their translations. "Some of your translations are out of date" feels rather negative, however.

I'd suggest having a "New translations are available" message, with a Details link. When the user clicks the details link they could be provided with a list of plugins/themes that have a translation available (if that is possible).

This also fits with the upgrade message already in use in WordPress ("WordPress 3.9 is available." - or if want to strictly stick to that message - "New translations are available. Please update [or install?] now.")

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.


7 years ago

#11 @DrewAPicture
7 years ago

  • Owner set to siobhan
  • Status changed from new to reviewing

@Siobhan, what's left here?

#12 follow-up: @SergeyBiryukov
7 years ago

I think it might be a good idea to hold off the changes here (and probably in #28201 too) until we get a better concept of what the actual i18n enhancements in 4.0 would look like.

#13 in reply to: ↑ 12 @DrewAPicture
7 years ago

  • Milestone changed from 4.0 to Future Release
  • Owner siobhan deleted

Replying to SergeyBiryukov:

I think it might be a good idea to hold off the changes here (and probably in #28201 too) until we get a better concept of what the actual i18n enhancements in 4.0 would look like.

Agreed. Punting.

@DrewAPicture
6 years ago

#14 @DrewAPicture
6 years ago

  • Component changed from I18N to Upgrade/Install
  • Keywords commit added; dev-feedback removed
  • Milestone changed from Future Release to 4.2
  • Type changed from defect (bug) to enhancement

I agree with Siobhan's suggestion about transforming the string into a positive with "New translations are available." to match core style on core updates. This is done in 28199.diff.

I think if we wanted to incorporate a details link, that would be a separate ticket.

#15 follow-up: @SergeyBiryukov
6 years ago

Looks like 28199.diff includes some unrelated changes from #31194 :)

@DrewAPicture
6 years ago

#16 in reply to: ↑ 15 @DrewAPicture
6 years ago

Replying to SergeyBiryukov:

Looks like 28199.diff includes some unrelated changes from #31194 :)

Whoops. Thought I reverted that. Added 28199.2.diff.

#17 @SergeyBiryukov
6 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reviewing to closed

In 31368:

Use a positive wording for translations update notice.

props DrewAPicture, siobhan, netweb.
fixes #28199.

Note: See TracTickets for help on using tickets.