WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#28220 closed defect (bug) (fixed)

Media Upload Thickbox Styles Broken After 3.9.1 Upgrade

Reported by: erayalakese Owned by: wonderboymusic
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.9.1
Component: Media Keywords: has-patch needs-testing
Focuses: ui, administration Cc:

Description (last modified by SergeyBiryukov)

Hello,

I'm adding a new metabox , with this functions. It's adding a new metabox which contains a link. And when user click to link , WP's default media uploader thickbox screen appears. It was working great at WP 3.9 version. But its styles broken after 3.9.1 upgrade.

http://i60.tinypic.com/2ues6jc.png

You can see this error with fresh WordPress installation. Just follow this steps :

1) Install WP
2) Add at least 5-6 images to your media library.
3) Add this codes to your functions.php file .
4) Browse to wp-admin > Add New Page screen.
5) Click Alt Başlık Görseli Ayarla link on Sayfa Alt Başlığı metabox.
6) Go to Media Library tab.

It was working great at 3.9 . But now there is a problem with Search Media textbox and button's position.

Thank you.

Attachments (1)

mediauploadjs.patch (3.0 KB) - added by erayalakese 6 years ago.
Patch for ticket #28220 . media-upload.js and media-upload.min.js files updated.

Download all attachments as: .zip

Change History (9)

#1 in reply to: ↑ description @erayalakese
6 years ago

I forgot to delete "I think i found a bug, but i'm not sure, so i'm asking here before reporting as a bug." . Sorry, i was post it on Testers mail group before sending this bug report.

#2 @SergeyBiryukov
6 years ago

  • Description modified (diff)
  • Focuses javascript template removed
  • Milestone changed from Awaiting Review to 3.9.2

@erayalakese
6 years ago

Patch for ticket #28220 . media-upload.js and media-upload.min.js files updated.

#3 @erayalakese
6 years ago

  • Keywords has-patch needs-testing added

media-upload.php's content doesn't fit to thickbox's iframe. Because of this, I've increased Thickbox's default width from 720px to 833px.

Last edited 6 years ago by erayalakese (previous) (diff)

#5 @ericlewis
6 years ago

I wonder if we can just disable MP6-styling in the old media modal (cc @melchoyce, @helen?). I don't think the proposed solution here is wide-reaching enough (changing the default width of the old media modal to sidestep the media query that breaks the styling here).

This ticket was mentioned in IRC in #wordpress-dev by ericandrewlewis. View the logs.


6 years ago

#7 @wonderboymusic
6 years ago

  • Owner set to wonderboymusic
  • Resolution set to fixed
  • Status changed from new to closed

In 28830:

The "old iframe media modal" has some pretty busted styles. Although this is a "deprecated" feature, clean up some of the broken styles.

Props erayalakese for the JS patch.
Fixes #28220.

#8 @SergeyBiryukov
6 years ago

  • Milestone changed from 3.9.2 to 4.0
Note: See TracTickets for help on using tickets.