WordPress.org

Make WordPress Core

Opened 15 years ago

Closed 15 years ago

#2829 closed enhancement (fixed)

Tabbed Editing

Reported by: skeltoac Owned by: skeltoac
Milestone: 2.1 Priority: normal
Severity: normal Version: 2.1
Component: Administration Keywords: rte quicktags has-patch needs-testing
Focuses: Cc:

Description

How about a way to go between TinyMCE and Quicktags without reloading?

Attachments (5)

tabbed-editing.diff (7.8 KB) - added by skeltoac 15 years ago.
tabbed-editor.png (20.0 KB) - added by skeltoac 15 years ago.
tabbed-editor.diff (20.1 KB) - added by skeltoac 15 years ago.
2829fix.diff (608 bytes) - added by westi 15 years ago.
And use the correct filename in the check!
tabfixes.diff (3.6 KB) - added by skeltoac 15 years ago.
clean up, remove comment rte, fix shrinkage due to missing cookie

Download all attachments as: .zip

Change History (34)

#1 @skeltoac
15 years ago

  • Keywords has-patch needs-testing added
  • Owner changed from anonymous to skeltoac
  • Status changed from new to assigned

It wasn't as hard as I'd expected. The patch tabbed-editing.diff works quite nicely for me. It needs testing with more complex markup but the basics are working.

Todo: better UI

#2 @markjaquith
15 years ago

  • Keywords needs-patch added; has-patch removed

Patch doesn't apply cleanly anymore...

#3 @skeltoac
15 years ago

  • Keywords has-patch added; needs-patch removed

new diff against rev 4205

improved UI. works in FF, IE, O9.

#4 @wnicholls
15 years ago

Gets my vote.

On the basis that if you don't ask for the moon, you'll never get it .. how about adding one more tab, ie

_/Compose\_/HTML\_/Metadata\__

Where 'metadata' means - excerpt, trackbacks, custom fields .. or go the whole hog and put categories et al as tabs too (No maybe not, see below)

I am constantly annoyed by having to scroll down past the trackbacks and customer fields to get to the preview at the bottom.

As as putting categories, post slug, parent page etc behind a tab - that's a bit of a can of worms . Sounds like something for a plugin, along the lines of WP-Dash.

#5 @ryan
15 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4206]) Tabbed editor from skeltoac. fixes #2829

#6 @zamoose
15 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

It appears as if this works under IE but NOT under Firefox or Opera (or Flock, for that matter). I've tried FF on Linux, OS X and Windows and can unequivocally say that nothing happens - the quicktags aren't loaded, nor is tinyMCE, nor are any tabs.

Further, the following error messages are logged to FF's JS console:

{{{ Error: Unknown property 'zoom'. Declaration dropped.
Source File: http://blogs.zamoose.org/wordpress1.6/wp-admin/wp-admin.css?version=2.1-alpha3
Line: 711

Error: Unknown property '-khtml-opacity'. Declaration dropped.
Source File: http://blogs.zamoose.org/wordpress1.6/wp-admin/wp-admin.css?version=2.1-alpha3
Line: 1108

Error: Unknown property 'filter'. Declaration dropped.
Source File: http://blogs.zamoose.org/wordpress1.6/wp-admin/wp-admin.css?version=2.1-alpha3
Line: 1109

Error: tinyMCE is not defined
Source File: http://blogs.zamoose.org/wordpress1.6/wp-includes/js/tinymce/tiny_mce_config.php?ver=09212006
Line: 36

Error: tinyMCE is not defined
Source File: http://blogs.zamoose.org/wordpress1.6/wp-admin/post-new.php
Line: 225

Error: Unknown property 'filter'. Declaration dropped.
Source File: http://blogs.zamoose.org/wordpress1.6/wp-admin/inline-uploading.php?post=-1158937830&action=upload
Line: 291

Error: tinyMCE is not defined
Source File: http://blogs.zamoose.org/wordpress1.6/wp-includes/js/autosave.js.php?ver=4206
Line: 73 }}}

The CSS errors are safe to ignore, methinks - those are just properties that FF doesn't parse correctly. However, the "tinyMCE is not defined" error is what's got me thinking something ain't stirring the Kool Aid.

#7 @zamoose
15 years ago

Three more notes, just so we're clear here:

  1. IE DOES work - the expected tabs are displayed.
  1. I disabled just about every plugin that does anything to the Write screen (UTW, etc.). No effect.
  1. Safari works as expected - it falls back to the quicktags since KHTML's JS handling is still wonky (come on, Apple! Make it work correctly - GMail, Writely and WordPress users alike will love you for it!).

#8 @skeltoac
15 years ago

zamoose, naturally we tested it in FF and O9 as well as IE. So, you're going to have to provide more information to help track down your issue.

What steps have you taken to resolve the issue: reload, forced reload, clear cache, different computer, svn di, new checkout?

#9 @zamoose
15 years ago

I'm afraid I'm not sure what svn di does, but this badboy was svn up'd as of 4208. I have encountered this issue, as I said, on three different OSes, two of which I did Shift-reloads (I'll clear their caches and try again). However, my FF-on-Windows test was using a new XP roaming profile that hadn't EVER been used to hit the site, so it had to be coming in cleanly.

I just cleared the cache on my MBP and tried a shift-reload under FF - still no joy in Mudville. Half of my testing environment is running behind a Squid proxy, but the MBP isn't, so there's nothing getting cached by a third party cache in between the server and my browsers.

And, as I stated before, it works under IE on a Windows box (which is using said proxy server) so I don't think it's a problem with my checkout.

#10 @ryan
15 years ago

When we've seen that tinyMCE not defined error in the past it was due to gzip compression settings. I wonder if that's at play here.

#11 @intoxination
15 years ago

I have reported the gzip error on 3144. The problem is that TinyMCE is not recognizing the option to enable/disable gzip output (from reading->options). If you are on a server without gzip installed, then this causes TinyMCE not to load.

#12 @westi
15 years ago

I had trouble getting this to work too.

It turned out that the call to file_get_contents in tiny_mce_gzip.php on line 39 was throwing an error which then ended up in the returned js which stopped both the quicktags and the wyswig editor loading correctly.

<b>Warning</b>: file_get_contents(.../wp-includes/js/tinymce/plugins/inlinepopups/langs/en.js) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory in <b>.../wp-includes/js/tinymce/tiny_mce_gzip.php</b> on line <b>39</b><br />

Attaching a patch to fix this issue

@westi
15 years ago

And use the correct filename in the check!

#13 @zamoose
15 years ago

I didn't think it was a gzip issue - I have gzip disabled on my test blog AND the whole thing works in IE, so it's not a server-side thing as far as I can tell.

I think westi probably has it correct - IE ignores the warning but FF is straight-ahead enough about the JS syntax that it refuses to load incorrectly-written script.

#14 @zamoose
15 years ago

Hmmm, hand-applied the fix - still no joy in Operaland nor Firefox City. FF JS console is still reporting the same errors.

#15 @zamoose
15 years ago

Small thought here:

I note that my <head> contains the following two lines:

<script type='text/javascript' src='http://blogs.zamoose.org/wordpress1.6/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=09212006'></script>
<script type='text/javascript' src='http://blogs.zamoose.org/wordpress1.6/wp-includes/js/tinymce/tiny_mce_config.php?ver=09212006'></script>

in that order. Might FF be flaking out because tiny_mce_gzip.php is being called prior to tiny_mce_config.php in the header?

#16 @skeltoac
15 years ago

Thanks for posting the urls. Now click the first one. It's blank. Check your PHP error logs.

#17 @foolswisdom
15 years ago

  • Component changed from Administration to General
  • Keywords rte added; wysiwyg removed
  • Priority changed from normal to high

#18 @zamoose
15 years ago

Ohhhhkay, then why does it show up under IE, I wonder? If I hit that link with IE, it returns a .php with the expected info in it.

Although it does prompt me to download it instead of just executing it server-side. Hmmmm.

As to "php error logs", I'm assuming you mean apache's error.log. This, unfortunately, has lots of "robots.txt not found" errors but zilch about errors in php.

#19 @skeltoac
15 years ago

I removed gzip,deflate from my Accept-Encoding request headers and got the js as expected. So it's a gzip problem.

#20 @zamoose
15 years ago

Okay. Suggested resolution, then? I have the gzip option disabled under Options->Reading, always have (it seems to take Dreamhost's servers twice as long to process gzip requests, for some reason). Do you think this is ocurring because FF is requesting a gzipped version while IE isn't?

#21 @ryan
15 years ago

  • Component changed from General to Administration
  • Priority changed from high to normal

#22 @zamoose
15 years ago

  • Component changed from Administration to General
  • Priority changed from normal to high

Okay, Andy's spot-on. If I delete "gzip,deflate" from network.http.accept-encoding (hooray for about:config), then Firefox willingly displays the file. When I put it back, it goes back to a blank display. Obviously I'd like to keep gzip requests on to reduce my browse times, so what's the long-term solution?

#23 @zamoose
15 years ago

  • Component changed from General to Administration
  • Priority changed from high to normal

Bollocks. Tagging went kablooie on that last comment. This is to fix it.

@skeltoac
15 years ago

clean up, remove comment rte, fix shrinkage due to missing cookie

#25 @zamoose
15 years ago

Might 3144 be applicable here? tMCE isn't verifying whether you've asked WP to disable gzip support...

#26 @zamoose
15 years ago

Although I do think figuring out why gzip is breaking tMCE is important, so maybe we shouldn't just punt (although the patch attached to 3144 looks like it'd do the trick).

#27 @activeingredient
15 years ago

Andy: why in tabfixes.diff did you remove the RTE in comment.php?? Your tabbed editing works great (in FF and IE) everwhere except in editing comments. It leaves a js error in IE ('tinyMCE undefined').

#28 @zamoose
15 years ago

The very simple patch in 3144 works for me. I'm going to try enabling gzip compression in the blog options to see what happens.

...And et voila'', everything's happy after applying that fix. The tabbed view works no matter whether gzip is enabled or not.

#29 @foolswisdom
15 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Closing bug as FIXED.

Based on update by zamoose, remaining issue is independent of tabbed TinyMCE and Quicktags and desc in #3144.

Note: See TracTickets for help on using tickets.