WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28372 closed defect (bug) (fixed)

Add inline docs for the full oEmbed providers list

Reported by: DrewAPicture Owned by: DrewAPicture
Milestone: 4.0 Priority: normal
Severity: normal Version:
Component: Embeds Keywords: has-patch
Focuses: docs Cc:

Description

Attached patch adds a markdown table of all of the currently-supported oEmbed providers and flavors (such as short links) to the oembed_providers filter.

Also reverts introduction of the single-use variable introduced in [25723] when the hook docs were added.

Attachments (3)

28372.diff (5.4 KB) - added by DrewAPicture 6 years ago.
28372.2.diff (5.4 KB) - added by DrewAPicture 6 years ago.
@see comes after @since
28372.3.diff (5.2 KB) - added by DrewAPicture 6 years ago.

Download all attachments as: .zip

Change History (9)

@DrewAPicture
6 years ago

@DrewAPicture
6 years ago

@see comes after @since

#1 follow-up: @Kniebremser
6 years ago

Hi!

I think wonderboymusic said to Viddler R.I.P. in changeset [28596]

Last edited 6 years ago by SergeyBiryukov (previous) (diff)

#2 in reply to: ↑ 1 @DrewAPicture
6 years ago

Replying to Kniebremser:

Hi!

I think wonderboymusic said to Viddler R.I.P. in changeset 28596

Yep, I had seen it, thank you. I'm currently waiting for the dust to settle there before I refresh the patch.

#3 @wonderboymusic
6 years ago

  • Milestone changed from Awaiting Review to 4.0
  • Owner set to DrewAPicture
  • Status changed from new to assigned

@DrewAPicture
6 years ago

#4 @DrewAPicture
6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 28949:

Introduce an annotated list of oEmbed providers, their flavors, whether they support SSL, and when they were added to the oembed_providers filter docs.

See #28507.
Fixes #28372.

#5 @DrewAPicture
6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I applied the wrong patch. Oops.

#6 @DrewAPicture
6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 28950:

Remove duplicate of the 'oembed_providers' filter accidentally introduced in [28949].

Move annoted table of oEmbed providers into the existing filter docs.

See #28507.
Fixes #28372.

Note: See TracTickets for help on using tickets.