WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#28378 closed defect (bug) (invalid)

Offline post writing could lead to overwriting the previous post

Reported by: vloo Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Revisions Keywords:
Focuses: administration Cc:

Description

Using Chrome 34 on Linux Mint 16.

  1. Open two "Add new post" tabs;
  2. Publish a post in the first tab -> it gets id=X
  3. Go offline;
  4. Write something new in the second tab that you opened;
  5. Go back online;
  6. Publish the new post from the second tab;

Result:

The post from the second tab gets id=X and the previous post becomes a revision of the new one. Slug of the new post is in effect when you got /%post_name%/ permalink structure and opening a link to the first post will lead to 404.

P.S. Could be somewhat related to #24447 and it's older twin-brother - #9604.

Change History (8)

#2 @adamsilverstein
5 years ago

vloo -

thanks for the bug report!

i wasn’t able to immediately reproduce the bug... Can you reproduce this every time?

can you clarify in step 3 when you say 'go offline' are you disconnecting your internet connection? how long did you wait before going back online? also, can you verify that you are using the latest version of WordPress and also try disabling all plugins and testing again? Finally, if you are know how or are adventuresome, can you try applying the patch in #28288 to see if that resolves the issue?

thanks.

#3 @adamsilverstein
5 years ago

  • Focuses administration added

#4 @vloo
5 years ago

I must admit both sites that I tested the issue were live environments with some plugins in action, but both 3.9.1. I'll test it on a clean install now just to clarify that it's WordPress, not a plugin (sorry for not thinking of this earlier!).

Step 3 is disconnecting from the Internet. Prior to that I don't have any text or even title input in the second tab. I stay offline for a couple of minutes, not a long period.

If I manage to reproduce it again, I'll apply the patch too.

#5 @adamsilverstein
5 years ago

OK, thanks.

I think the bug is WordPress and possibly related to autosaves, if we can nail down a way to consistently reproduce we may be able to figure it out. Also, if the other ticket patch gets accepted i think this will solve your problem. it may not be a plugin issue, i only ask because it is good to rule out this possible issue.

This ticket was mentioned in IRC in #wordpress-dev by adamsilverstein. View the logs.


5 years ago

#7 @vloo
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Can't be reproduced any more. I guess it was fixed at some point or the original report I did was under the influence of some plugin.

#8 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.