Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#28393 closed defect (bug) (fixed)

Login logo is cut off slightly

Reported by: drewapicture's profile DrewAPicture Owned by: helen's profile helen
Milestone: 4.0 Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords: has-patch commit
Focuses: ui Cc:

Description

Noticed that the logo svg on the login screen is being cut off slightly along the bottom edge.

http://f.cl.ly/items/3q2c1z4117013p383y2d/Screen%20Shot%202014-05-29%20at%2012.12.00%20AM.png

Attachments (3)

28393.patch (1.2 KB) - added by SergeyBiryukov 10 years ago.
28393.after.png (13.8 KB) - added by SergeyBiryukov 10 years ago.
28393.diff (1.6 KB) - added by helen 10 years ago.

Download all attachments as: .zip

Change History (12)

#1 @DrewAPicture
10 years ago

  • Milestone 4.0 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hmm, seems intentional after looking at 3.8/3.9 login screens. Maybe I just never noticed it.

#2 @ocean90
10 years ago

I'm seeing this only in Firefox and this can't be intentional. If someone can come up with a patch feel free to re-open.

Seems like increasing the height/width by 4px to 84px fixes it.

Last edited 10 years ago by ocean90 (previous) (diff)

#3 @johnbillion
10 years ago

  • Milestone set to Future Release
  • Resolution invalid deleted
  • Status changed from closed to reopened

Seeing this too in Firefox (29).

#4 @SergeyBiryukov
10 years ago

  • Keywords has-patch added
  • Milestone changed from Future Release to 4.0

Confirmed in Firefox. Bumping the height doesn't fix it for me, but 28393.patch does.

#5 @SergeyBiryukov
10 years ago

  • Keywords commit added

#6 @helen
10 years ago

I'm not sure making it smaller is the right answer. Do we know what's causing this? I'm not turning up anything, and it seems to be directly related to the actual size of the background image (maybe a rounding issue, although that doesn't make sense going from 64 -> 80). I think I'd rather go a little bigger if we need to change the size.

#7 @ericlewis
10 years ago

After playing around with it, seems like a rounding issue as @helen suggests. The original is 64x64, bumping background-size: 79px 79px works all the way down to background-size: 75px 75px, where the problem represents itself.

This ticket was mentioned in IRC in #wordpress-dev by helen. View the logs.


10 years ago

@helen
10 years ago

#9 @helen
10 years ago

  • Owner set to helen
  • Resolution set to fixed
  • Status changed from reopened to closed

In 28850:

Slightly bump up the login logo size to avoid getting chopped off by Firefox's rounding problems. props SergeyBiryukov for the initial patch. fixes #28393.

Note: See TracTickets for help on using tickets.