WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 4 years ago

#28411 closed defect (bug) (fixed)

Remove misplaced label from submitdiv and remove some obsolete css

Reported by: iseulde Owned by: afercia
Milestone: 4.7 Priority: normal
Severity: normal Version: 4.3
Component: Editor Keywords: has-patch has-screenshots
Focuses: ui, accessibility Cc:

Description

There's a label wrapped around "Status:" in the post submit box, which is clickable, but doesn't do anything.
At the same time there are also some CSS rules in forms.css for the icon before it that are a duplicate of the styles found in edit.css for the other icons.

Attachments (3)

28411.patch (2.4 KB) - added by iseulde 6 years ago.
28411.2.patch (3.1 KB) - added by afercia 5 years ago.
28411.diff (5.2 KB) - added by afercia 4 years ago.

Download all attachments as: .zip

Change History (18)

@iseulde
6 years ago

#1 @iseulde
6 years ago

  • Keywords has-patch added

#2 @iseulde
6 years ago

left: -1px; also doesn't seem to make it look any better at all. top: -1px; for this one icon neither.
There's also no reason to remove the text-decoration, because there is none.

#3 @SergeyBiryukov
6 years ago

  • Milestone changed from Awaiting Review to 4.0

#4 follow-up: @SergeyBiryukov
6 years ago

There's a label wrapped around "Status:" in the post submit box, which is clickable, but doesn't do anything.

It actually does focus the dropdown if you click "Edit" first. I'm not sure if it's necessary though.

#5 in reply to: ↑ 4 @iseulde
6 years ago

Replying to SergeyBiryukov:

Yes, but then it should (1) open the hidden area and (2) work the same way for all sections.
I'd actually prefer that above having an "edit" link next to every section.

#6 follow-up: @helen
6 years ago

Probably a good idea to reveal the area when you click the label. Doesn't seem like a good idea to remove the label element - semantics.

#7 in reply to: ↑ 6 @iseulde
6 years ago

Replying to helen:

Probably a good idea to reveal the area when you click the label. Doesn't seem like a good idea to remove the label element - semantics.

Okay, then labels should be added to each line there.

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.


6 years ago

#9 @DrewAPicture
6 years ago

  • Milestone changed from 4.0 to Future Release

Punting per IRC. Sounds like clicking the labels should be made to be more interactive anyway. Patch still applies.

#10 @chriscct7
5 years ago

  • Keywords needs-patch added; has-patch removed

Needs a new patch to address Helen's comment as well

@afercia
5 years ago

#11 @afercia
5 years ago

  • Focuses accessibility added
  • Keywords has-patch has-screenshots added; needs-patch removed
  • Version set to 4.3

I'd agree the "Status" visible text shouldn't be a label, for consistency with other elements in this box. The status select should have a label though and I'd propose to add a hidden one, as already done for the timestamp select.

The "Publish box" probably deserves some major improvements and re-thinking. It would be nice to get rid of the small "Edit" links, which are a bit tricky for accessibility, and make each single "row" clickable. Maybe each "row" (Status, Visibility, etc.) could be marked up as a button that, when clicked, would reveal the related stuff. Or, to keep the "no-js/js" compatibility they could stay as links but have a role=button added via JavaScript. Additionally, aria-expanded attributes should be used to give assistive technologies users some feedback about what happens when the links/buttons get activated. The "Revisions" row is an exception, since it's a real link.
Worth considering also to simplify things, for example removing barely noticeable title attributes :) see screenshot below:

https://cldup.com/zTX-zzmJtR.png

Basically many things can be experimented and tested here but for now I'd recommend to follow the approach of the patch by @iseulde, just adding a new hidden label. See the refreshed patch.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


4 years ago

#13 @afercia
4 years ago

  • Milestone changed from Future Release to 4.7
  • Owner set to afercia
  • Status changed from new to assigned

At the very least the label issue should be fixed, hopefully for 4.7 :)

@afercia
4 years ago

#14 @afercia
4 years ago

Refreshed patch. Adds a role="button" attribute to the "Edit" links.

#15 @afercia
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 38700:

Accessibility: Editor, Publish meta box: remove a stray label and redundant CSS.

Also, adds a role="button" attribute to the "Edit" links.

Props iseulde.
Fixes #28411.

Note: See TracTickets for help on using tickets.