Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#28417 closed feature request (invalid)

Update required for text widget

Reported by: rajanit2000's profile rajanit2000 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Widgets Keywords:
Focuses: administration Cc:

Description

Wordpress not displayed normal text widget when move to another server. I think its a small issue for core team.

Attachments (1)

widget.png (41.8 KB) - added by rajanit2000 10 years ago.
content of the widget not shows when i move to another server

Download all attachments as: .zip

Change History (6)

@rajanit2000
10 years ago

content of the widget not shows when i move to another server

#1 follow-up: @lpointet
10 years ago

It's probably due to a wrong update of your database in the migration: text widgets are serialized into the database, and if you only run a basic search & replace routine, it may breaks the serialization, making the widgets disappear.
Even if serialization could be avoided, this is not a core bug in my opinion.

#2 in reply to: ↑ 1 @rajanit2000
10 years ago

Replying to lpointet:

It's probably due to a wrong update of your database in the migration: text widgets are serialized into the database, and if you only run a basic search & replace routine, it may breaks the serialization, making the widgets disappear.
Even if serialization could be avoided, this is not a core bug in my opinion.

So what i think its a bug. If it is solved its very useful to us

#3 follow-up: @ocean90
10 years ago

  • Component changed from General to Widgets
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Type changed from feature request to defect (bug)

Please try the support forums for troubleshooting: https://wordpress.org/support/

#4 in reply to: ↑ 3 @rajanit2000
10 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Type changed from defect (bug) to feature request

Replying to ocean90:

Please try the support forums for troubleshooting: https://wordpress.org/support/

May i know it is bug or not. I post this review because i never except this on next wordpress version. what is my mistake?

#5 @SergeyBiryukov
10 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

If you need to change the domain name in your database dump, you should use Safe Search and Replace or a similar tool to do that without breaking serialized data like widgets or theme settings.

If you didn't change your domain name and still have a problem with text widgets, please try the support forums for troubleshooting.

Feel free to reopen with steps to reproduce on a clean install if it turns out to be a bug in core.

Note: See TracTickets for help on using tickets.