Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#28418 closed feature request (duplicate)

register_plugin_directory needed

Reported by: miljushm Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Plugins Keywords:
Focuses: Cc:

Description

Hi guys,

we have awesome function register_theme_directory which makes registering additional theme directories very flexible and I think having the same (register_plugin_directory) for plugins is something we need so bad.

I am aware of activate_plugin function but it's not flexible at all, at least not near register_theme_directory since only plugins located in the /plugins/ directory or /plugins/my-example-plugin/ can pass the validation (validate_plugin and get_plugins), otherwise it returns that plugin doesn't have good headers which is another confusion.

Cheers!
Marko

Change History (1)

#1 @ocean90
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19721.

Note: See TracTickets for help on using tickets.