Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#28450 closed enhancement (duplicate)

WordPress XML export contains data for all authors

Reported by: khromov's profile khromov Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Export Keywords:
Focuses: Cc:

Description

When running a WordPress XML export (Tools > Export), the wxr_authors_list(); function is called to output a list of authors at the top of the exported document.

This happens regardless of filters you have specified.

Say that you are exporting data for a single user only, I don't see why we need the XML to include login names and email addresses for all other users on the blog.

I don't have a patch as of yet, wanted to see if this is "working as intended" first, but I would be happy to submit a patch that limits the authors list depending on the export filter specified.

The use case for this is that we want users on our site to be able to export their own data only. This can be done via available filters but we can't stop wxr_authors_list(); from outputting all the author email addresses on the site in the export.

Change History (2)

#1 @johnbillion
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20206.

#2 @SergeyBiryukov
10 years ago

  • Component changed from General to Export
  • Summary changed from Wordpress XML export contains data for all authors to WordPress XML export contains data for all authors
Note: See TracTickets for help on using tickets.