WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#28491 closed enhancement (duplicate)

Only local image uploads are possible with the customizer

Reported by: dpknauss Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Media Keywords:
Focuses: ui Cc:

Description

Adding images to WordPress through the post editor, theme customizer, or anywhere else requires uploading an image (or selecting a previously uploaded image) in the media library. It's not possible to specify an arbitrary image file by URL or select an image from the media library (for logos, etc.) in the theme customizer, nor is it possible to replace or remove an existing image. This means the media library will accumulate a large number of likely redundant images from typical user behavior where someone adds an image to a post, remove its, modifies it outside of WordPress, and then adds it again. After these actions, both new and old versions of the image will be present in the media library.

Change History (2)

#1 @SergeyBiryukov
5 years ago

It's not possible to specify an arbitrary image file by URL or select an image from the media library (for logos, etc.) in the theme customizer, nor is it possible to replace or remove an existing image.

Appears to be a duplicate of #10950, #20602, and #21483.

#2 @helen
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21483.

Note: See TracTickets for help on using tickets.