WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#28513 closed task (blessed) (fixed)

Add a tab on the plugin installer for features as plugins

Reported by: nacin Owned by: nacin
Milestone: 4.0 Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: administration Cc:

Description

If you're running a development build of WordPress, let's give you a 'Beta Testing' tab on plugin-install.php.

As a shortcut (and because it's easier to implement this way and does no harm), it'll actually respond to plugin-install.php?tab=beta on any site, though of course that may change with plugin install screen changes in 4.0.

As of right now, the plugins are json-rest-api, wp-front-end-editor, and press-this. These are hard-coded on api.wordpress.org for the moment, but trivial to change/update.

I could also see us adding a "Development" tab that lists plugins like Debug Bar and Log Deprecated Notices. (Again, only if not on a stable build.)

Note that "development" here includes develop.svn/git.wordpress.org, even if running a stable version of this. This is by design.

Also note that the WordPress Beta Tester plugin is omitted, since you already need to be on a beta track to get here, and may just confuse people.

Change History (3)

#1 @nacin
4 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 28749:

Add a new 'Beta Testing' tab on the plugin installer, for features as plugins such as Press This.

fixes #28513.

#2 follow-up: @Offereins
4 years ago

Curious, why was the tab not introduced as part of the WordPress Beta Tester plugin, as the tab is only used in that context?

#3 in reply to: ↑ 2 @helen
4 years ago

Replying to Offereins:

Curious, why was the tab not introduced as part of the WordPress Beta Tester plugin, as the tab is only used in that context?

That is not the only way to be running a development version of WordPress - you can download a nightly manually or run trunk from the SVN or Git sources.

Note: See TracTickets for help on using tickets.