WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#28525 closed defect (bug) (duplicate)

Wordpress (TinyMCE) eats up paragraph tags if you leave the post, then go back to it

Reported by: archon810 Owned by:
Milestone: Priority: normal
Severity: major Version: 3.9.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

On two of my sites (at least using Chrome stable), I've been noticing random loss of paragraphs where text separated by just new p tags gets merged into a single paragraph. If the separators are images, the paragraphs don't get joined, so it's only for text as simple as

<p>a</p>
<p>b</p>

This makes entire posts unreadable due to them becoming a wall of text.

To reproduce:

  • load any post with multiple consecutive paragraphs.
  • leave the page by going to another site, for example press View post.
  • press Back in your browser and observe the paragraphs merged after TinyMCE loads. Sometimes you may need to leave the page twice, but for the most part, once is enough, in my testing.

I've tried on two different sites, one that disables autop and one that doesn't, and both are affected.

This is a pretty serious issue because it's destructive, so I'm inclined to give it a high priority, if I could.

I'm going to attach several images comparing before and after.

Attachments (2)

before.png (55.2 KB) - added by archon810 5 years ago.
Original text
after.png (52.4 KB) - added by archon810 5 years ago.
After leaving the page and coming back to it, paragraphs merged

Download all attachments as: .zip

Change History (4)

@archon810
5 years ago

Original text

@archon810
5 years ago

After leaving the page and coming back to it, paragraphs merged

#1 @archon810
5 years ago

  • Severity changed from normal to major

#2 @azaozz
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28037.

Unfortunately Chrome doesn't care about autocomplete="off". It keeps "auto-filling" the editor textarea when the user clicks the Back button regardless... Only solution known to work for now is to set autocomplete="off" on the whole form.

Last edited 5 years ago by azaozz (previous) (diff)
Note: See TracTickets for help on using tickets.