WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28553 closed defect (bug) (duplicate)

Wordpress Revision system should count Metadata changes as new Revisions

Reported by: alexbowyer Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Revisions Keywords:
Focuses: Cc:

Description

I experienced some issues with lost post data when developing a WP site using the themify.me "page builder" which stores a lot of the post data for posts and pages into custom fields on the post. The problem I had was that my previous changes to a page did not exist as revisions.

It seems that Wordpress only creates a new revision when you change major fields such as title or post body - but not when you change custom fields or metadata fields.

I think that Wordpress revisions should track ALL changes to a post or page, no matter how minor... Otherwise when people use custom fields or page builders, they don't get the benefits and peace of mind of the revision system.

Change History (2)

#1 @Denis-de-Bernardy
6 years ago

Probably invalid: the API allows plugin and theme authors to trigger additional revisions as needed.

#2 @helen
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Realistically, this is a duplicate of #20564, although I see that the ticket description specifically talks about revisions created when pressing a button in the UI. It's possible to work around this in the meantime, which seems like might be a good idea for page builder features that store data in meta - I have done this very recently.

Note: See TracTickets for help on using tickets.