WordPress.org

Make WordPress Core

#28653 closed defect (bug) (fixed)

Media: Attachment Display Settings inside Galleries don't work

Reported by: designsimply Owned by: wonderboymusic
Milestone: 4.0 Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords: needs-patch
Focuses: javascript Cc:

Description

Steps to reproduce:

  1. Create a new post
  2. Click the "Add Media" button
  3. Upload or select a few files
  4. Click "Create Gallery" on the left
  5. Click the "Create a new gallery" button at the bottom right
  6. While on the "Edit Gallery" screen, click on one of the images, and scroll down on the right until you see the "Attachment Display Settings" section
  7. Select "Link To" = "Custom URL" under "Attachment Display Settings" at the bottom right
  8. Enter a URL and click the "Insert gallery" button
  9. Click the "Edit" icon on the gallery to go back to the "Edit Gallery button screen again
  10. Click the the image you just added a Custom URL to
  11. Look to see if the Custom URL is still present
  12. Try setting the link to none and checking it again, it doesn't save that option either. In fact, alignment saves, but he link and size settings don't. I'm not sure the Attachment Display Settings" options should even be present in that screen though.
  • Expected: Attachment Display Settings like "Link To" on the Edit Gallery screen to save and work on images inside galleries as expected
  • Actual: Attachment Display Settings on the Edit Gallery screen don't work


Tested with core trunk r28663 and on WordPress.com.

Reported by a WordPress.com user who was unable to get Custom URLs to work—I think we are semi?-merged up to r28625.

Attachments (1)

Screen Shot 2014-06-26 at Thu Jun 26 5.05.57 PM.png (587.0 KB) - added by designsimply 11 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 @designsimply11 months ago

511559 (ignore this)

comment:3 @wonderboymusic11 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.0

Let's take a look

comment:4 @wonderboymusic11 months ago

  • Focuses javascript added

comment:5 @ircbot11 months ago

This ticket was mentioned in IRC in #wordpress-dev by sheri. View the logs.

comment:6 @Ipstenu11 months ago

This is a regression from 3.9 where that field is hidden when you're in the gallery.

If you do want it (and frankly, I do) there's a plugin: https://wordpress.org/plugins/wp-gallery-custom-links/

Suggest it get removed from the 4.0 editor for galleries :) Unless we're using it for real and then I love you.

comment:7 @ircbot10 months ago

This ticket was mentioned in IRC in #wordpress-dev by wonderboymusic. View the logs.

comment:8 @wonderboymusic10 months ago

  • Owner set to wonderboymusic
  • Resolution set to fixed
  • Status changed from new to closed

In 29285:

Don't render Attachment Display Settings when display is set to false. Currently, the value for display in the media.view.AttachmentsBrowser instance in the media.view.MediaFrame.Select frame is set to the value for displaySettings.
These values do different things, so check for the existence of display on the state before arbitrarily setting it to the displaySettings value.

Real world: this hides display settings when you select an image while editing a Gallery.

Fixes #28653.

Note: See TracTickets for help on using tickets.