WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 months ago

#28656 closed defect (bug) (fixed)

When pasting in Chrome or Safari, <strong> and <b> may be replaced with spans

Reported by: azaozz Owned by: azaozz
Milestone: 4.0 Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Happens when font-weight is set for these tags in the CSS (not set by default in WordPress but themes add it).

Caused by the same *wonderful* feature that adds tons of spans with inline styles producing super ugly unstylable HTML.

Change History (2)

#1 @azaozz
7 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 28866:

TinyMCE: force 'font-weight: bold` for <strong> and <b> inside the editor or Chrome and Safari may replace them with spans on pasting. Fixes #28656.

This ticket was mentioned in Slack in #core-editor by itsjusteileen. View the logs.


7 months ago

Note: See TracTickets for help on using tickets.